32GB micro SD not being recognized, or available to format.


purchased a Sandisk microSD card, and went to put it in my gopro and it read SD ERR. so i formatted it, and no  joy.

tried putting the card in another electronic device (camera) to format, and still no joy. it kept saying i had to format it again, immediately after i formatted it.

i put the miniSD in the adapter and in to my computer, and it immediately brought up a formatting tool to format it. It only showed 30.8 MB of available space to be formatted, and even that for some reason could not be done. 

Tried downloading multiple formatting tools and same result, no reformat is available. 

Upon discovering the large number of counterfeit 32gbs, i downloaded the tool to detect counterfeits, and it wont even let the tool access to determine if its counterfeit. 

Not sure what other possible solutions there are. And the write protection switch is definitely not active.

any and all help would be appreciated! Thanks in advance!

@lew272 wrote:


Not sure what other possible solutions there are.

Return the card for a different one.