Sandisk SSD doesn't show up in Windows 7...

I just got my Sandisk ReadyCache SSD today. Very excited! Installed it in the spare hard-drive slot in my laptop (G50VT-X5). Then I went in BIOS and the SSD was there. So far so good! However, once in Windows, I could not find the SSD anywhere: Device Manager, Disk Management, Disk Part. 

So I have tried these things:

  1. Went in BIOS and switched the SATA configuration from “Enhanced” to the other 2 options: “Compatible” and “Raid”. Both of those gave me BSOD. Couldn’t boot…

  2. Tried to install Intel SRT 11.2 which I heard works. Windows refused to install it, claiming the driver is already up to date and is functioning properly. 

  3. Spend another hour looking for solutions on Google. Most people who had similar problems could actually see their SSD somewhere either in Device Manager or Disk Management. Mine is simply nowhere to be found. 

Any good ideas on where I could proceed from here?!

Thanks a bunch!

is the SSD detected in the BIOS? have you tried other ports and cables?

Yes, it is detected in BIOS.

I’m installing it in my laptop (G50VT-X5) so there’s only one port available (no cable was needed). 

You can’t change the SATA mode without first making changes to the registry. This is probably what caused the BSOD when you changed the SATA mode. 

If it is detected in the BIOS it should show in disk management. Do you have a External enclosure or different computer you can try the SSD in to confirm if the SSD is functional? 

I have an external enclosure! I will give that a shot tonight! 

How should I change the registry to be able to change the SATA mode?!

Thanks for your help, drlucky!

Personally I would just reinstall if I wanted to change the SATA mode. You can research changing SATA mode after OS installation if you want to give it a try.