Sandisk Extreme 120gb SSD unrecognised by computer.

Hello all, I finally received by SSD today after quite a lengthy wait and upon plugging it in, I strangely found it was unrecognised when I tried to install Windows 7 on it. I reset and went into the BIOS and found that although my two old hard disks were recognised by the computer, the SSD wasn’t showing up. I tried to manually detect the disk but it insists there’s nothing there. I’m a bit confused as to why this might be, any ideas? It’s as if it’s not plugged in, and being totally silent I have no idea whether the SSD is even working or not!

My motherboard is an Abit AN8-V (Socket 939) with an AMD 64 (think it’s the 3400, not sure) and 4GB of RAM.

I hope you’ll be able to give me some ideas as I’m totally stumped!

Thanks a lot,


There is not a whole lot you can try really if the drive is not detected in the BIOS. basically you just need to make sure the SATA port where the drive is connected is enabled, try different ports and cables, and if all that failes try it in another computer or USB enclosure. If the drive is still not detected it will need to be replaced. 

I’ve double checked all the connections and everything’s fine. Today I put it in a USB enclosed on another computer and managed to successfully format it. Does definitely seem to be working fine, so why won’t my computer see it?

Enclosure, sorry!

Old mother board and BIOS that does not understand what “SATA III” is, which is communicated in the SATA protocol. There may be nothing you can do about this, unless a miracle BIOS update at this time.

My motherboard is indeed SATA I, so would it definitely not work if that’s the case? No chance of an update, the last update for my motherboard hails from 2007 unfortunately and it’s already installed. Would an SATA III card maybe do it?

IMPORTANT UPDATE: I just booted up the computer that won’t recognise it - with it plugged directly into the motherboard - using an Ubuntu boot CD (not running from any hard disk) and the OS recognised and allowed me to access the disk. So the motherboard must be capable of recognising it in some way! Now, does anyone know if there’s any way of getting Windows 7 to recognise and install to it so I can get this computer up and running again?

you can try using diskpart to delete and recreate the partition on the SSD. If this does not work you may be out of luck on that MB. 

1. Insert the DVD into the DVD drive.

2. On the disk selection screen, press SHIFT+F10. A Command Prompt window opens.

3. Type diskpart , and then press ENTER to open the diskpart tool.

4. Type list disk , and then press ENTER. A list of available hard disks is displayed. 

5. Type sel disk number , and then press ENTER. number is the number of the hard disk that you want to clean. The hard disk is now selected.

6. Type det disk , and then press ENTER. A list of partitions on the hard disk is displayed. Use this information to verify that the correct disk is selected.

7. Make sure that the disk does not contain any data as this will erase all data, type clean all , and then press ENTER to clean the disk. All the partitions and all the data on the disk is permanently removed.

8. Type exit , and then press ENTER to close the diskpart tool. Close the Command Prompt window. Click the Refresh button to update the disk selection screen. The SSD should show up as unpartitioned now. 

Yo, sup, i had a same problem a second ago but i found this awsome video that helped me. You probably didnt select the volume for your SSD! HERE IS THE LINK:   HOPE I HELPED! :smiley:

Awwwwwwww…thanks,lots of ideas and helps…,!!!

Oh…really…it worked…thanks ….!!!

Yes, the SSD is detected everytime in my desktop PC but only sometimes in my laptop. Depending on where i try to put it (I have two hdd in my laptop = msi GX780R) it is never detected, the PC responses slow or it sometimes could be detected in BIOS but then not from Win7.
With the original hdd,the laptop works perfect in ahci mode.

here there are three ways to fix this: