Extreme Pro SSD suddenly no longer detected in bios.


I bought an Extreme Pro SSD 480g 2 weeks ago, pluggeg it, migrated my system(win8.1) and games to it and it worked without problem and with excellent performances for several days.

Then yesterday, after booting my pc, using it for a few minutes and leaving it idle for an hour or so, i found it stuck on a BSOD.

Powered it off

And now the drive is no longer detected in the bios (MSi Z87-G45-GAMING)

All my other hard/optical drives are working.

I’ve tried to :

* unplug, and replug it.

* plug it with different data / alim cables on different sata ports

* reset bios options, wait an hour with it plugged to power only, several cold reboots…

* even put it in another computer (different motherboard)

not detected…

I’ve contacted (french) support about it ([Incident:140722-000473]) but thought i could also post here in case anyone had an idea, or seen this happening.

This model is quite new, so it might be an undetected firmware problem.

While it was working , i tried to check for updates with the Dashboard, but no newer version was found (around 12th of July)

Also i wouldn’t know how to update it as no software is seeing it connected (bios/windows install dvd/gparted) 

Or it’s just bad luck and i received a defective device…


If the SSD is not detected in the BIOS even after everything you have tried there really is not anything you can do to recover it. SanDisk will likely want to bring the drive in for analysis since it is such a new product. Support should let you know whee and how to return it for a replacement.  

Hi , I met the same issue as yours.

But my situation is a bit better because BIOS can detect it. But if I plug in to another machine, it can not be detected.

Is it possible that I can download an ISO firmware? then maybe I can update the firmware and see if it can work or not.



Could you please let me know where I can download ISO firmware for Extreme Pro ?

there is not a FW update for this ssd.

Because this issue has happend several times for different people,

I think maybe it is a design issue or firmware issue.

I also have the same problem.  I installed this drive into a laptop and everything was working great for a couple of months.  I recently suffered a BSOD and then was having performance issues with the laptop locking up.  I would have to do a hard reset on the laptop.  Upon the most recent hard reset, I got an “operating system not found” error and it will no longer boot. I went into the BIOS and it is not detected.  I tried reseating the drive to no avail.  It looks like there may be an issue with these drives…

I experienced the same problem TWICE. The drives refused to work in the middle of Windows Update. I cannot connect to it anymore (internally or using USB enclosure). Now I need to start another RMA process. err…