960GB Ultra II SSD dissapeared from BIOS

Good morning,

I have the 960GB drive (SDSSDHII-960G) for just a year. It has served me well over the period and had no issues with it until this morning.

Turned on my PC and the BIOS couldn’t find the SSD. Changed it’s cable socket numerous times trying every other, power socket, reset the CMOS. Left the PC off for 1 hour away from the power. Nothing.

I cannot test it until Monday on a different system unfortunately, but is this it? Only option is to RMA the drive?

I’m having the same problem. My SSD disappeared after doing a forced shutdown (holding power button for 5 seconds). I’ve had to do the forced shutdown many times in the past because my laptop emerges from hibernation/sleep with a black screen and a dead keyboard. Computer has always rebooted fine until now. I’m going to plug the SSD into a desktop to see if it shows up there.


I have the same problem, after shuting down my Laptop, it already does not want to start the next morning, tried to check the SSD on other pc and it cant find it. I think the firmware is corrupted, any luck on recovering your SSD? I really need to recover my files. TIA

if the ssd is not detected in the BIOS and you have tried it on another computer and the same issue occurs the ssd is likely bad. For data recovery you can contact a company that provides data recovery service. For warranty replacement contact sandisk support and check the warranty status. 

1 Like

As Drlucky said. Best option is to test it on a second PC as an internal and external drive. if it doesn’t work then the drive has failed.

This is a pretty common problem in most SSD drives and when you get a replacement test it as an external medium for a while and update firmware.

You can get more help here: http://www.tomshardware.com/answers/id-3020977/ssd-disappeared-bios.html