SanDisk Ultra II 480 died

 Anyone else here have this problem? Came home one day and it was just dead. As in, dead as dirt.

Can’t see it in my bios. Or another pc’s bios. I even put it in my dock. Nada. RMA is in process. 

Was just looking at reviews at Newegg. LOTS of dead or DOA units. My RMA drive arrives today. I think it will go on eBay.

Welcome to the the club. I bought a 960gb, and a 480gb last year. Both failed! SD was great with the rma process, but I will NEVER purchase a SD SSD again. WAY too many failures.

My 480 Ultra II died 4 months after install. I have to go to BB to get a receipt printed to do RMA. I have owned many drives, this was my first SD. I thought since the USB drives are so robust they had to know what they were doing. Nope- Back to SAMSUNG for me. What a pain in the neck, and Web search finds this a common issue where drives fail with no notice.

SSD Ultra II 960gb just died on me.

I have two of these and have checked them on an external usb to sata on another laptop. The second one is fine and becomes visible in Dashboard and I can access the files.

The first one that has my windows operating system and most of my files on it is dead and does not show up anywhere.

In the original laptop it worked fine since April 16, but just switched on laptop and then nothing and it’s gone. 

I assume it is the end of the story for recovering the files from it because it is no longer visible to a pc.

Mine died less than a year,  

Laptop suddenly didn’t boot up and took out the SSD and plug into SATA socket/USB and verified it’s not detected in any USB port.  I’m an engineer in electronics but no idea where the issue is, I guess control block died rather than flash area, so I wonder I can recover the data.

My 480 died less than an year. Suddenly laptop didn’t boot up and I took out the SSD and put into the other laptop with Sata/USB but not detected at all.  I put the original HDD into the laptop that I used with SSD, it works okay. so I guess the SSD might be damaged by surge or something. Since USB port doesn’t detect the SSD with Sata, I guess controller block got damaged, rather than flash areas.  so I hope I can get the data recovered.

My Sandisk Ultra II 960 just died as well. Fresh out of the box, it just wouldn’t be recognized in the BIOS, in windows and didn’t work when I used a SATA to USB adapter. I have another working SSD that I checked with these same conditions and that one worked just fine so I’m positive it’s the Sandisk Ultra II 960 that I got.

Doing some research tonight was necessitated after my fourth in a low number of drives having failed today.  There is a fair amount of discourse concerning drives that were somehow firmware-frozen, for lack of a better term.  They can be brought back from non-detection by simply powering them idle, with/without a SATA cable (depedent on the source) on the BIOS screen.

Here is Crucial’s knowledgebase article: .

I would like to believe this may be a fix for the these drives’ problems and intend its attempt.  Some sources denote 24 hours and that is the goal.  Can anyone relay positive, negative or otherwise results regarding SanDisk’s models concerning this or a similar procedure?  Testing with dmesg is mentioned, as are discharging the mainboard, different signals used by firmware flashing software and hot-plugging.  I am not looking to switch as I was pleased with the price/performance up until recently.  Your contributions are appreciated.

Yup , just had one Ultra II die on me  just the other day after about 18 months (used in older Evga X58 desktop) and going to do an rma today (finally found the receipt) . Still have one in a laptop going on 2yrs with no problems . 

My other Sandisk (Extreme 480) in my x99 game rig is running just fine .

Add one more casualty to list. Ultra II 480GB. Worked for about 6 months. Started getting write errors for about 1 month then just dead, not detectable in BIOS.

Tthe same here: SD Ultra II 480 GB bought on 27.11.2015 from Amazon worked flawlesly untill yesterday.

Now it is not even recognized in BIOS.

Any solutions out there?

Also after registering it I see it is in warranty - any idea how to exchange it if I am not located in the US (SSD was bought in US from US

If it is not detected in the BIOS it will need to be replaced. You will need to contact sandisk support to get an RMA. you can put in an online RMA request. return process may be different depending on what country you are in. Go to the link below and use the language selector at the top left. If you are in Europe make sure and use English (Europe) to get you to the right team.  

same thing happened to me . I honestly dont care about warranty. but going forward I’ll not use SSDs. Too unreliable, we’ve had 5 SSD drives dies. MTBF figure are all false.  Every SSD seems to die at between  to  years. My belief is Microsoft OS is the problem, pagefiles system and other  background  burns controllers and cells out.   Some place claim they can retore SSD data by:

a) replacing the controller, or

b) replacing the connector.

immediately after getting the drive up back up  copy all data to new drive.

My ultra 2 960gb died too. It was barely over a year old but I’ve not really had my pc on much during the year so the ontime and data written woukd still have been low.
Luckily my windows install is on my Samsung 840 evo that’s over 2 years old and I have a 1tb hd for storing documents but the ultra 2 was just for steam, origin and other program installs so my pc is still running. Currently waiting on rma and if this replacement fails I just hope it’s within the 3 year warranty period…(fingers crossed I get an upgrade lol)

1 Like

Mine and my brothers 240GB and 120GB have both died this week. Brought at different times, mine is only 3 months old. And we live in sperate towns. Both run the sandisk ultra 2

Another one bytes the dust…

Ultra II 480 about 9 months old

Croaked. Nothing in BIOS. Nothing on any program. Tried the plug into power but not data for 20 mins, cycle twice… still nothing.

A complete brick.

Not going to bother with an RMA since the replacement will likely be just as prone to complete failure in the future.

Another to the list Ultra ii 480. no warning signs, woke up to dead pc, boots direct to bios. pulled and put into external dock and nothing. Have heard it could be a bad controller chip. If anyone has info on this repair please reply as I have some data I have to retrieve.

My thoughs exactly, why RMA you also loose any chance of data retrieval.

theys video may help you a bit if you want recover data

and you may consider watching eevblog or ohter youtube channels to learn soldering if you want recover data.

just look soldering  tutorials videos.