SanDisk "SecureAccess is already running" error

Just to share some information with others who might face similar issues with SecureAccess v3

My SecureAccess V3 gave a “SecureAccess is already running” error where I cannot open it and therefore cannot type my password to enter the vault to retrieve my existing files within the vault. I contacted SanDisk chat - and the support person gave 2 solutions:

  1. alt+ctrl+del > go to disk/task manager >second tab( processes)

If you can find SecureAccess there, delete it and try to open the SecureAccess again normally.  (I think she meant try to kill the process)

  1. If you cannot find SecureAccess there, please uninstall and reinstall SecureAccess again. Instructions are on the article bellow:

SanDisk SecureAccess 3.0 support information and download page

The 2nd solution worked for me.  It required me to uninstall the existing SecureAccessV3_win from my USB stick, then download the new SecureAccessV3 (from Download for PC on that webpage - link above), copy this new version to my USB stick to replace the older one.  Then click it to open it, and it should work.  I did not delete anything else. I think any existing files/data you have already stored into the vault is stored in the SecureAccess Vault itself, so do not delete or uninstall anything else except the SanDiskSecureV3_win!  I was worried that I could delete any encrpyted files within my vault, but only replacing the SanDiskSecure V3_win did not affect those files, so I need not have worried.

I hope it helps.

I solved this by removing 2 files, “lock” and “lock.rmlock” from the “SanDiskSecureAccess Settings” (I think) folder.

However, now i have to delete “lock” every time I want to use it.

It worked like a charm! Thank you sir!

Wow, like a charm; however I had my Documents folder disappear after installing an upgrade on Encryptstick vault so I could sync. After syncing it disappeared. I’d hoped I might find it in the old vault! thanks for the tip