Problems opening my sanDisk - BEFORE typing my password.. hmm..

Hello,

I have already one sanDisk , which works just that fine. About a month ago I bought a new one for back up my things.

Now I wanted to back up some documents once again, and when I click on the “RunSanDiskSeccureAccess_win” button -

I get a pop up window which says: “SanDisk SecureAccess is already open. To se your current session you have to click on the actual SanDisk SecureAccess-window”. 

I am a bit confused…

Luba

Mine has been doing the same thing just lately after months of use. Piece of crap and no answer from Sandisk I see. I’ll never buy another product of theirs again if this drive wont even let me access my ‘secure access’ files…pff. bad bad product, terrible support.

Have you written to SanDisk support about your problem??  Just curious.

I’m having the same problem to as anybody found a solution?I had a little “chat” with them which takes quite a long time and the only thing they gave me was how to install it

With the USB drive not plugged in and you open the Task Manager window do you see SecureAccess listed?

I ran into this problem a couple times and was able to resolve it: It seems to be caused when you plug in the flash drive, run the program, unplug the flash drive, then plug it in again without turning the computer off. The easiest way to resolve it is to plug the flash drive in, and if it gives you the error about the program already running or won’t go past the vault graphic, then while leaving the drive in, restart your computer. Then when it comes back on, it will automatically bring up the login screen and will not have anything running in the background to cause a conflict.

The other way I found is: go into your tasks: Processes and Applications, find the “RunSanDisc” item by pressing the R key, and click “End Process.” Then go back to the drive and underneath the icon that you click on to run the application, there’s some kind of temp file that it always creates when you click the vault icon: You will need to delete that temp file. Then click the vault icon and it should create a new temp file and run the program.

Using an almost new SanDisk Ultra USB 3.0 32GB, working back and forth between several computers with files I was moving around, I began getting the message “already running” upon clicking the application RunSanDiskSecureAccess_Win.  I tried some of the above suggestions, which did not work as described but gave me an idea that did.  I opened the folder SecureDiskAccess Settings, looked for the most recently created .dat file, noticed it contained the word “lock” in it, and deleted that file.  Problem solved - apparently.  Am now again using this thumb drive as intended.  

How did I create this problem to begin with? Probably by mindlessly yanking the thumb drive out without logging out and/or dismounting it from computer A, then attempting to use it again in computer B.

Time will tell if there is more to this problem than it now seems.  If the problem recurs, I will follow up on this post.

2 Likes

Hi,

I tried looking up the Task Manager to stop the running application, I restarted the laptop with SanDisk pendrive still in the slot but I am still getting the ‘Secure Access is already running’ message. 

I tried to locate the recently created .dat file in ‘SanDisk Secure Access Settings’ folder and found it to be ‘Config.dat’. I didn’t want to modify or delete this file as was suggested in earlier post as I am aprehensive of totally destroying the drive. Similarly, I found ‘index.dat’ and ‘version.dat’ files as recently created files under ‘SanDisk Secure Access Vault’ folder and agin I didn’t want to touch them with a fear of currupting all my files.

I my situation I accessed the SanDisk in the morning in my home laptop, I had logged out of it and then removed the drive. Now I am trying to use the SanDisk at my work laptop and getting this message. All the above remediation task that I performed were on my work laptop and not the laptop that I had accessed the SanDisk successfuly in the morning.

Pls. someone help me how I can get over the ‘Secure Access is already running’ message.

thanks a lot,

Sam

This worked for me but,  slightly different, there was a file called lock, I renamed it and was able to open my vault again!  Thank you for getting me to this resolution!

Thank you SO much.  This worked for me.  I was freaking out a little as I bought a new laptop a few days ago and backed everything up to the sanDisk.  Phew!  What a relief.

I have tried deleting that lock file but it doesnt delete… It gets fakely ‘deleted’ for a second but it actually reappears when I refreshes the page or exit that file and return to that file. 

And is SecureAccess running when you try this?  You don’t have to be signed on to it, just have the signon window open.

Thanks for the solution. I’ve been with support thru emails for a week & they couldn’t help me. Their useless in my opinion.

Thanx Again

1ccmorris1 - thank you for the following solution: I opened the folder SecureDiskAccess Settings, looked for the most recently created file, noticed it contained the word “lock” in it, and deleted that file.

Thank you worked for me! Mine in particular was a Symantec “lock” file that somehow got created. As soon as I deleted it, I could run the RunSanDiskSecureAccess_Win.exe application without getting the “already running” message. Whew!!

Thanks again!