SanDisk Secure Access V3 fails to start

I haven’t been able to figure out how to configure the USB drive to Safety only (Can you please tell me how to in windows 10? I didn’t find the settings in device manager). In the mean time I was able to run chkdsk. Chkdsk was able to recover most of the lost files however still having my error. Maybe if I can change the settings as suggested then there would be a chance.

It is worth mentioning that since running chkdsk windows now recognizes the drive again when I connect to a com port but SanDiskSecureAccessV3_win still won’t open with the same missing 4 dll error.

…also the drive folder has SanDiskSecureAccess Vault and SanDiskSecureAccess Settings folder with config.dat and filesystem.dat in it. I was just wondering if the SanDiskSecureAccess Vault and/or the 2 files above can be used to recover missing dlls or maybe dare I dream, something else?.

The vault opens fine

“The vault opens fine”

Sounds like you’ve made progress benon1.  :smiley:

Worked for me, too!  Thanks!


Sorry I had to take a business trip.

No, unfortunately I haven’t made much progress, at least none useful. Files still not accessible. Look at the attached picture. What I meant is the vault opens fine. That’s the file folder in third position from top or bottom. What contains the files though is the win application at the very bottom. That still doesn’t open. It doesn’t open since I removed the drive unsafely.

You indicated there is a way to change setting for USB drives and that is where I am struggling. If you could show me how to do that in windows 10 then maybe I can get some results and recover my files sandisk.jpg.

“” there is a way to change setting for USB drives and that is where I am struggling. If you could show me how to do that in windows 10"

plug in the USB drive
open Windows Explorer
RIGHT click on the USB drive
click Properties
click Hardware
click on the Name of the USB drive
click on Properties
click on Change Settings
click on Policies
ensure Removal Policy is set for Quick Removal

However, the file at the bottom of your picture is the SecureAccess executable.  That is what runs and accesses the files in the vault.

It was already in that position (default).

Yes, it is the default but some people, and things, change it.  At this point the only recommendation I have then is to use the Safely Remove option on the Taskbar when you have a flash drive plugged in and want to remove it.  It’s what I do regardless of the machine I am on, including my own.

Copy that.

I still wanted to ask if this was worth any new consideration.

I moved the old SanDiskSecureAccessV3_win that doesn’t open to my desktop and replaced it with a a new one that O downloaded. It open’s but I get a “wrong path” or “vault has been moved”. Does that shed any new lights? See screen shots vault0.jpg vault1.jpg

Before you copied the new download to the flash drive did you delete all the files & folders on the flash drive?  If not please try doing that  then copy the new download over and try executing it.

WTF is this?  

Brand new memory sticks arrived today.

Launched “SanDiskSecureAccessV3_win.exe”

Immediately went into message stating update available - bug fixed etc.

Downloaded update

Then displayed a message stating failed to remove SanDiskSecureAccessV3_win.exe

Here’s a suggestion chaps - if you’re going to ship something which can potentially shag one’s data - at least make sure it works properly before depolying.

1 Like

Hey Ed,

Quite interesting what’s happening. I seriously don’t think I should give up on this drive. I went ahead and removed all but the new installed “SanDiskSecureAccessV3_win” and the vault and upon launching secureaccessV3 now I get a very interesting welcome you now have the most secure encryption … then next popup “it appears you already have a vault installed, do you want secure access to use it?” “yes” and my heat beating lie crazy waiting, hourglass and then sthg like “windows has stopped working…” . That was really close this time. I feel we should continue trying things after the holidays. I keep you posted with new developments

Hey benon1,

Good to hear you’re still enjoying the new drive.  :smileyvery-happy:

I think you should have deleted the vault files also when you restarted.  Nothing on the drive but the SecureAccess app.  In fact maybe deleting it also and with the drive completely empty starting over with a fresh download.  

Enjoy your holidays and travel safely.

1 Like


What does it mean to rename it?  How do you do that?


@shadolyst wrote:

Renaming the *.exe worked for me too. Thanks, @ssguitarist

I have been using the Sandisch Secure Access V3 for a few years now. Most of the time it works fine but around 1 in 10 times, when I click to open the file it just seems to freeze with this on screen (see attached picture).

I have tried renaming the .exe file, closing it and trying again but the only thing that seems to work is restarting my PC. This can be a pain as it means I have to save and close everything. Do you have any suggestions to fix this without shutting down?



I purchased a SanDisk Secure Access USB a few weeks ago.

I haven’t been able at all top install and run the Secure Access software.

When I launch it, it looks for updates, then says that it will restart, but then it fails ALL the TIMES.

I tried to delete the software and re-install it. Unfortunately, this is NOT an option. I am NOT allowed to uninstall/delete any file from the USB. My only option is to launch the program, which does not work.

What should I do?

thank you,


> I am NOT allowed to uninstall/delete any file from the USB.

This sounds like a Windows security app problem.  SecureAccess files are easily deletable.


I have stored files in the vault on version 3 and successfully accessed twice before today.

When I have tried to open the vault today I cant, I receive a pop message that reads: 

ScanDiskSecureAccess is already running

I have hit task manager there are no processes running,

The vault shows up on the USB window, however the only files that show under the USB drive in the computer menu on the left hand side of screen are the 3 folders:

SanDisk SecureAccess

SanDiskSecureAccess Settings

SanDiskSecureAccess Vault

not the application where all the files are:


Any ideas on how to get back into the vault?    (it is the same PC that I am trying access from that I used to copy the files across initially)