SanDisk Cruzer Fit 16 GB, changed to RAW? cant recover files


I recently bought a SanDisk Cruzer Fit 16 GB. I’ve used plenty of USB drives before and never had any problems, but i have made sure to get new ones every now and then. So I started using the drive, everything seemed fine and I loaded som (mistake, i know) important files on it, thinking they would be safe on a new drive. Then today I tried using the drive. I inserted it, and instantly it asks me to format. I didn’t, but I had a look at the meny and I would only be able to format it to 20mb or so. I tried to use a number of softwares to see if anything would be possible to recover. I tried using Partition Master to recover the partition and programmes like Recuva. Now the USB is stuck on a RAW file system in addition to some other very small partition. Any suggestions? Id really like to get my data back! :( 

  I loaded som  … important files on it, thinking they would be safe on a new drive.

“Important files” are safest when they are on multiple drives, in case something happens to one of the drives.

If you had tried using CHKDSK on the drive when it asked to be formatted you might have been ok but at this point I think your files have gone to the bit bucket in the sky. :frowning:

Such situation is extremely serious. Formatting of your drive is only a way to convert its file system from RAW to NTFS or Fat 32 and probably fix the not formatted error, but before you formatted it, get the important files from the drive by a free data recovery program.The following links are just two examples…

1 -  Free Any Data Recovery

2 - Recuva - File Recovery - Features

Good luck…

# 1 -  Free Any Data Recovery

Free for the 1st 500 MB , then it’s $49.95 according to this link:

Here’s how you recover data from SanDisk USB flash drive - recover data from sandisk usb

Here’s how you recover data from a RAW hard drive - recover data from RAW drive