Sandisk Cruzer Pop 16GB in RAW format and unformattable.

Hey people,

I have a Cruzer Pop 16GB, which is in RAW format since my pc shutdown when I was formatting it sometime ago. After this, any attempt to format it failed, including diskpart, gparted, so called “HDD Low Level Format Tool”, Windows Quick Format, HP Format Tool, etc. As you can see, I’m kinda desperate about it, since I have no warranty right now, and I really need it (no files in it). Also, I tried in inumerous computers, Windows, Mac, Linux, everything you can think of. But the only thing i haven’t tried is flashing its firmware, which worked for most of my corrupted drives from Sandisk and Kingston, since I can’t find the formatter neither the firmware, it’s the only thing I haven’t tried.

I’m even thinking of learning russian to enter those freaky usb-hardware soviet forums, lol.

Thanks in advance guys,

Please help me

:smiley:   Gabrielw6,

Dear member of SanDisk Community, welcome.

Please friend, do not grieve more, return it, is dead, ist kaputt…

You might have a pleasant surprise, if can contact with SanDisk Technical Support who will replace the device if it’s authentic and is within warranty.


To obtain the internal data of the UFD, you can use the portable utility (free): USB Flash ChipGenius 4.00,

To find out more on this, see here:


Regards, Alfred.                                                            (Google translated)

Hi Gabriel, how has this been working for you so far? Was this unit dropped or anything. I’d suggest an RMA on this if it’s an option for you. Or if it’s still under warranty.