SanDisk Cruzer Contour 8GB Not Working


Please help

I stopped working with the (SanDisk Cruzer Contour 8GB) flash drive. Connecting the flash drive light flashes for a few seconds and the Windows operating system displays a message “USB Device Not Recognized”

I tried several ways to fix:

  • using Windows installation disk (diskpart or installing process),
  • using “Disk Management”,
  • Ubuntu OS “Disk utility”

but no one method did not show my USB device :frowning:

possible to fix my USB device? or hardware is damage?
can help any firmware reinstall or other method?

Please help, I’m sorry for the spelling mistakes, I am Lithuanian so I used Google Translate.

I added a video of the device is not working:

video on youtube

Or is it any virus? Because I tried to connect the usb to the same computer that was connected to and then fail to Cruzer Contour. It is now no longer than one USB flash drive.
Maybe you can help to repair or reformat the USB, because the operating system does not see reasonable USB flash drive???