Sandisk Cruzer Blade 8Gb not recognized when creating bootable disk

I am using Novastor to create a bootable disk. The process works perfectly when I insert a Sandisk Facet 8Gb or Sandisk Ultra USB 3.0 flash drive. But no matter in which USB port I insert the Cruzer Blade 8Gb, the software won’t detect the flash drive.

Windows 10 Device Manager and Windows Explorer detect all three Sandisk drives types without issue.

Any idea why the Cruzer Blade is problematic?

I can’t think of any reason.  Have you asked Novastor?

They are mystified as well. I can plug three Sandisk USB flash drives into my three USB ports and the ISO writing part of the process will show me only the Facet and Ultra USB flash drives. Never the Blade, regardless of which port it is in.

Very strange.  It would be helpful if Novastor would display an error msg as to why it can’t work with the flash drive.  Bad blocksize, bad drive start addess, something useful.

Have you formated the drive?

Yes, both as NTFS and FAT to see if that made a difference. Tried different USB ports as well. There’s really no error message possible. The software interrogates the hardware looking for external drives, flash drives or a writable CD in the CD drive to present as a list of potential targets from which the user can select.
I’ve had a similar issue in the past in which a firmware update program wouldn’t recognise a Blade flash drive. That was a different computer and OS and a different Blade flash drive, too.

I’ve tried a couple of other ISO burning tools including WizBurn and none of them recognise that a brand new and otherwise fully functional Cruzer Blade USB has been inserted. As soon as I insert a Facet or Ultra USB, either of them is identified by the software immediately.

There seems to be something different about the Cruzer Blade that ISO burning programs don’t like or recognise.

Another update and another clue as to the cause of the issue.

The Sandisk flash drives that can be ‘seen’ by the ISO burning tools are seen as being “Removable” in Disk Manager. The drive that doesn’t work in the ISO burning tools appears in Disk Manager as “Basic”, in other words, it’s not seen as a removable drive.

I tried deleting the partition and recreating it through Disk Manager but that didn’t make any difference.

So now the queston becomes:

How do I change the bit set on the Sandisk Cruzer Blade such that it can be recognised as a removable drive?

Thanks in advance.


Try RMPrepUSB.  It’s always worked for me in the past.

1 Like

I can’t think of any reason.