Cruzer Blade USB Flash Drives 16 Gb Acts like a normal harddisk, and not USB Flash Drive

Hi… Bought 3 of your Cruzer Blade USB Flash Drives 16 Gb…

But when i plug them is they doesn’t act like a USB Drive. But like a normal Harddisk… So now i can’t use them for the purpose that i bought them for. The purpose was to make bookable USB Drives… When using the program to make them bootable etc. they don’t show up.

What to do?

Using Windows 7 (64Bit)

Newer flash drives, to be compatible with Microsoft’s Windows to Go feature of Windows 8, have to be set as Fixed drives rather than Removable.  Check with the vendor of the app you use to make the drives bootable and see if there is an update.  Or consider a different boot app.  Which app are you using?

Well i don’t think it is a matter of which program i use… Programs like that are made to use USB Flash Drives. so when the USB FLASH DRIVE isn’t acting like a USB FLASH DRIVE anymore the programs doesn’t work… LOGIC wouldn’t you say…

But why is it then that is it only your USB FLASH DRIVES that does this **bleep**??..

AND you kinda saying that in the future there is no bootable USB Flash drives cuz they all act like harddrives??

There are several vendors making USB drives that support Microsoft’s Windows to Go concept.  http://www.microsoft.com/en-us/windows/enterprise/products-and-technologies/devices/windowstogo.aspx  And I suspect it will be the new standard at some point for all USB flash drives.   So no, I don’t think bootable flash drives will go away, I think booting apps will be updated to support the newer flash drives.  Have you tried RMPrepUSB?

You would want that USB to be bootable first. Out of the box, it’s not configured that way.

I am even facing the same issue with my Cruzer Blade which wont work either on XP Vista win 7 or 8. Shows as local disk and unable to make it bootable.

Any suggestions?

Thanks!

Have you tried RMPrepUSB?  What app(s) are you using to make your other flash drives bootable?

I am currently using Rufus and even tried RMPrepUSB but issue is still the same. Also, recently i saw an article from your knowledgebase http://kb.sandisk.com/app/answers/detail/a_id/12830/kw/fixed%20disk

what shall I do now? My softwares will only recognize the drive when it will apear as Remoavble disk.

More info:  http://reboot.pro/topic/16429-easy2boot-development-discussion/page-14#entry175111

The current version of RMPrepUSB should work with the Fixed Disk formats.  If you prefer your existing booting apps write to their vendors and ask them when they will update their apps for use with the new USB flash drive standards.  These are the only two options I see that you have.

Surely there must be a way to flip the removable bit on the drive? 

I’m trying to set up a 32Gb Cruzer usb drive as a bootable recover drive, and to do this I need to use the MSI Boot Recover application… So far it has created the image, but whenever I plug in the drive (as prompted by the program), it does nothing because the USB drive is “not removable” and therefore not detected as a usable drive… MSI have been quite clear that there software is not at fault and they have no plans to update it… and to be fair, their software does work just fine… Providing the USB drives being used are set to actually be USB drives… not fixed drives. 

So like I say… there has to be a way of getting that to work, right? (I hope this isn’t going to be yet another case of “it’snot us, it’s them” back and forth)…

MSI have been quite clear that there software is not at fault and they have no plans to update it… and to be fair, their software does work  just fine..”

I’m sure their software does work fine on the old style USB flash drives but Microsoft has dictated a new direction.  MSI can ignore it and stay with the old style drives and will soon find themselves with a shrinking market.  It happens.

Find yourself old fashion drives and you will be find.  SanDisk has decided to follow Microsoft’s directions.

You might consider returning your Cruzer to where you bought it and see what they suggest.

SanDisk have broken Windows installs for me with this.

When Windows Setup runs (Vista and later versions), Setup will look for a file called \AutoUnattend.xml on a  removable  drive.

It’s all well and good saying you NEED to make them fixed for Windows2Go, but this breaks other parts of windows.

Valid point.  Have you written to Microsoft and asked how they intent to handle this?  They’re the ones pushing the fixed disk standard and it’s their software.

I have little doubt that they simply don’t intend to handle it.

Firstly, they are not going to issue updates to OS’s from Vista up, they want to sell 8 (although, 8 still has the issue).

Secondly, they want to push Windows2Go for the BYOD crowd, as it’s one of the few things that might actually sell 8 to the enterprise.

A better way would be a SanDisk utility to flip their drives into Fixed or Removable modes, or to change the firmware on the drives.

"Surely there must be a way to flip the removable bit on the drive? "

If you find it let us know.

Have you looked at RMPrepUSE’s Easy2Boot app?

https://sites.google.com/a/rmprepusb.com/www/tutorials/72—easyboot—a-grubdos-multiboot-drive-that-is-easy-to-maintain/e2bv1 

If I had one of the new USB drives with the Fixed Disk feature I would try it myself but I don’t.  It’s free so give it a shot and let us know if it helps.

Many Lexar USB Flash drives can have their removable bit ‘flipped’ using the Lexar BootIt utility. I am not sure if Lexars more modern Win8ToGo flash drives work with BootIt though as I have not got one.

I your USB software needs to find AutoUnattend.xml on a removable drive, then a simple solution is to plug a small cheap removable USB flash drive into the system as well as the SanDisk ‘fixed disk’ flash drive - Windows will then pick up the AutoUnattend.xml from the small flash drive when it boots to Windows. Easy2Boot also supports this 2-drive method.

RMPrepUSB will work with USB Fixed disks - just press Ctrl-Z or use the Settings menu tab.

This trend of shipping USB flash drives as ‘fixed disks’ is getting more prevalent - manufacturers should provide a utility like BootIt to enable these drives to be converted to either fixed or removable. If not, then they are going to lose sales, receive returns and get many more complaints. They should also clearly state in the specifications which type it is shipped as. Having a ‘flip’ utility would increase sales and SanDisk should seriously consider producing controllers and utilitities which support this.

1 Like

RMPrep and Easy2Boot are exactly why I want the drive removable, they work on a non-removable disk but you can’t install windows from them, and they don’t have a way to flip the bit.

Yes, you can use a 2nd stick that is removable to load AutoUnattend.xml, but if I’m going to have to buy 2 sticks I’ll retrurn this useless Sandisk one and just get a removable one that works.

Wow, I’m confused. 

Ok, a dumb question, Windows installs are designed to run from a CD, which is non-writable, how/why does running the ISO from a flash drive, removable or fixed, cause this removable requirement???  The standard CD install has a CD and a hard drive.

confused

Windows PE v2/3/4 all have a feature where on boot up, they look for an \Autounattend.xml and/or \Unattend.xml on a removable drive (CD or removable USB drive). E2B uses this feature so that when a Windows Install ISO boots to WinPE to run Setup, WinPE finds the \AutoUnattend.xml file in theroot of the USB FLash drive. In that file there is an entry to find and run a .cmd file located on the USB flash drive (loadiso.cmd). The .cmd file runs firadisk or ImDisk and loads the Windows Install ISO that is on the E2B boot drive into memory as a virtual DVD drive. Now when Setup runs, it looks around for a DVD drive containing the Windows source files and finds the virtual DVD drive - voilla - it can now see the \sources\install.wim file on a ‘DVD’ and is happy.

If the virtual DVD drive was not loaded before Setup runs, Setup would complain about a ‘missing CD/DVD device driver’ as it would not be able to find a CD/DVD drive with the \sources\install.wim file (and other files on the DVD).

Ok, gotcha.  Windows is not looking to write to the drive it’s looking to read a removable drive and a CD is  Removable!!  So Easy2Boot uses IMDisk or FiraDisk to load the ISO to RAM as a removable DVD.  Very clever SteveSi.  So this should solve the Fixed disk USB problem.

Thank you SteveSi.