Fixed/Local Flash Drives.

As I understand the situation, flash drives had (almost?) always identified themselves as Removable. With the release of Windows 8, SanDisk made the decision that their drives would identify themselves as Fixed/Local, i.e. not Removable. 

However, Sandisk then had a change of mind and reverted to Removable. Unfortunately, their packaging does not appear to clearly state which identification the flash drive provides. Nor have they made available a tool for converting Fixed/Local to Removable.

Almost every one of my numerous flash drives is bootable (utilities, anti-virus, etc.). Unfortunately most utilities for creating bootable flash drives simply don’t see Fixed/Local flash drives (e.g. Norton Bootable Recovery Tool, Acronis Rescue Media Builder).

If I have correctly summarised things, then my three-pack of Cruzer Facets is the last SanDisk purchase I’ll ever make.

Regards,

David.

Not all utilities for making bootable flash drives on Fixed drives are unworkable, just the old unsupported ones.  Try RMPrepUSB.  Personally I would write to the vendors of the apps you use and complain.

If the 3 pack you purchased doesn’t work for you you should return them to where you bought them and get others or your money back.

2 Likes

Thanks, Ed, your RMPrepUSB suggestion proved to be an excellent workaround! (FWIW, I used it to install grub4dos on the drives. I then copied in the ISOs (and/or extracted files from them) and set-up a menu.lst using information from http://www.rmprepusb.com/tutorials/grub4dos/grub4dos_examples plus some trial and error.)

Small addition, many current supported utilities also can’t handle Fixed drives (e.g. Norton’s NBRT). I suspect that it’s simple economics - companies are allocating their resources to where the main traffic is.

Many Thanks,

David.

DId you try the Easy2Boot multiboot project? No need for cheat codes to boot linux ISOs. Just copy the ISO file over and boot.

Hello Steve.  Does Easy2Boot work with UEFI systems?  Without switching the BIOS to Legacy mode?

Steve,

Everything is working fine for me (albeit after a small amount of set-up), so including a third level seems excessive.

Of course, if I come across a product that I can’t easily add then I’ll certainly be giving Easy2Boot a try out.

(I’m not sure what you mean by “cheat codes”. Isn’t menu.lst an integral part of grub4dos?)

Regards,
David.

Hi

No Easy2Boot does not work with UEFI - you must boot in BIOS mode to use E2B :frowning:

re. cheat codes - if you want to use grub4dos to boot from an ISO, then you need to tell linux where the ISO is located, and also what it is called once the kernel is loaded. This is typically done with ‘cheat codes’ or kernel parameters, e.g. 

kernel /casper/vmlinuz file=/cdrom/preseed/backbox.seed boot=casper iso-scan/filename=/backbox-3.0-i386.iso quiet splash –

If you extract the ISO files, then you can tell the kernel where to find the casper/squashfs files using a cheat code like ’ live-media-path=/images/fdraptor/casper’

 

Thats is what I mean by cheat codes. You have to use these with most grub4dos multiboot implementations. This can lead to problems because not all linux distros support these cheat codes which means you can’t boot them from an ISO file. Also many linux kernels don’t support NTFS, which means even if you extract the files from the ISO onto your USB drive, they will not work if the USB drive is formatted as NTFS.

Easy2Boot uses a different technique - it uses the partnew command in grub4dos to make a primary partition containing the contents of the ISO file. In this way Easy2Boot can boot 99% of all linux ISOs just by copying them to the USB drive. No cheat codes are required and the ISO is not changed and no grub4dos menu needs to be made by the user.

HTH

Steve

P.S. re.  Removable v. Fixed

To have a USB Flash drive as ‘Certified for Windows To Go’ it must be of the Fixed Disk type. This is dictated by MS. If you try to run Win8ToGo on a Removable USB drive you run into compatibility problems during use/updates, etc… You can however add a USB fixed disk driver (cfadisk) to fix this and you can then run Win8ToGo on a Removable USB Flash drive. It is a pity MS didn’t just ‘autodetect’ that the drive is of the ‘Removable’ type on boot and install a similar driver to make it appear as a fixed disk to other apps. Instead they made all the USB Flash drive manufacturers change their USB Flash drives to the Fixed type!

So if the drive is Certified as Windows To Go it will be a Fixed Disk type - if not, then it will probably (??) be a Removable type but there is no guarantee!

It is annoying that:

a) Manufacturers don’t specify which type it is

b) They don’t provide a tool like  BootIt.exe to flip it between Removable and Fixed.

Steve,

Thanks for the useful posts. I absolutely agree with your final couple of points and feel that SanDisk have really shot themselves in the foot by failing on both counts.

It’s particularly ironic that not one of the 9(!) Windows to Go certified flash drives is a SanDisk.

Regards,

David.

No Easy2Boot does not work with UEFI - you must boot in BIOS mode to use E2B :frowning:

The Windows 8 Rescue USB that Windows 8 creates boots on both UEFI and non-UEFI machines.  On the Windows 8 machine it boots to the rescue system, on the Windows 7 machine it boots to the hdd’s Windows 7 system.  If that latter process could be tweaked to boot to the OS on the USB drive…

But this proves that a single drive can be booted on UEFI and non-UEFI machines. 

It’s particularly ironic that not one of the 9(!) Windows to Go certified flash drives is a SanDisk.

Most likely because SanDisk no longer makes them.  Either not enough demand or not worth the customer service hassle.

Ed,

Either not enough demand or not worth the customer service hassle.

Yes, I suspect it’s demand. On the face of it, Win2Go seems like a great idea. However, there’s been so little take-up by manufacturers that I’m guessing that the corporates have some fundamental issues with it.

Regards,

David

I’m calling BS on SanDisk’s “Solved! Go to Solution”.   I used RMPrepUSB on a problem SanDisk drive, and it did not work.  The text in the executable window was moving so fast (and I forgot the command to freeze it) but at the end my eyes caught the word “Fixed Disk” and “Windows” so I think RMPrepUSB was saying it could not complete the operation and Windows will recognize the flash drive as a fixed disk.  Never buying a SanDisk product again! 

I wasted about 3 hours trying to get their d*@&^ flash drives to be recognized as removable drives. I cannot get that part of my life back.Really angry at SanDisk. 

Hi, Dan.

As the person with the original issue, it was I, not Sandisk, who flagged Ed’s post as a solution. His solution didn’t convert the drives to Removable (simply not possible, afaik), but did enable me to create bootable, Fixed/Local SanDisk drives - which was all I was trying to do in the first place.

To help resolve your issue, you might consider posting in the RMPrepUSB support forum. Also, I subsequently took Steve’s recommendation and tried out Easy2Boot. It’s a simple, quick and effective way to produce a flash drive that can boot into multiple programs/operating systems.

Regarding the error messages that disappear too quickly, you might try looking for a log file in which they’re recorded. Failing that, I’ve captured such messages by using screen recording utilities (Camtasia in my case).

Cheers,
David.

 I used 2 visually identical (do not remember exactly) such https://encrypted-tbn3.gstatic.com/images?q=tbn:ANd9GcQBuDn3_TIIHsBSeirR7JE0IKk1Zm8mR0mdW5mx9DER7Lgh6u-bog

drives. First one was recognized as removable drive ,it was lost. I got new one - recognized as fixed one. No mention about Win2Go at the packaging. I should buy new one that will be recognized as removable one. Can I recognize it by packaging?

Found one detected as removable in our lab. A difference - only in serial number (lowermost number at the drive)

DavidOn and taras_m, Thanks for your replies.

The RMPrepUSB solution was not allowing the SanDisk to show up as “Removeable” for the SONY VAIO software. So even if RMPrep could have allowed me to create a bootable drive, maybe VAIO Care created an additional level of complexity. I called SONY support and asked about deleting all SONY Software from the machine and running clean Windows, but the support person said that the driver support might not be there on the recovery disk that I created with clean Windows. It sounded like more complexity and time.

Although I have no formal training in computers, I used to manage 14 computers at a law library.  And I had them highly optimized for efficiency that they rean beautifully. I cut out all the Windows and IE crap, and the machines flew as fast as they could for 2004 era machines. (IE was the program we had to use for compatibility for certain legal software).   I used Deep Freeze so nobody could alter the config. (Unless I did when installing updates). Now if I were still managing those computers, I probably would have been up enough on how to do this kind of thing that I would have been able to do the RMPrepUSB fix, or, since I was getting paid for it, I would have devoted the time and concentration necessary to do it. But not being a professional, and not getting paid for this, and having another job et cetera, I just didn’t have the time or concentration.

So David, since you and not SanDisk flagged this as the solution, I’ll hazard a guess that for a professional, it is a solution, and maybe if you are running clean Windows, it is a solution.  Also, I’ll state that it is quite disappointing that apparently SanDisk hasn’t done much at all to try to help people utilize this entire production line of USB drives.  Or least they should issue a warning displayed at Staples, and brief the Staples tech people (those guys in the black and green shirts) that the line of SanDisk drives they are now unloading at discounted prices cannot be used to create recovery disks in Windows 8 without additional work.

Luckily, I found a sympathetic manager at Staples, who allowed me to exchange the openned SanDisk drives for a Kingston 32 GB.  I inspected the package, and it said it works with Windows 8, but there was no “Windows 8 Certified” symbol. I also did an online chat with Kingston support before I openned the packaging to make sure the drive would show up as “Removable”.   It was the “Data Traveler” line of Kingston, and I am not sure if it was “G2” or not, but it looks the same as G2.  I had to leave on travel the next day so things were hectic.  The Kingston drive showed up as “removeable” so that the SONY VAIO utility software could “see” it and create a recovery disk.

For people who may be reading this, if you buy a Kingston USB drive, as long as it only has the “Works with Windows 8” box checked, and doesn’t say “Windows 8 Certified” and does not have the Windows 8 symbol, you should be okay- the drive should show up as “Removable Disk”.

Hi

Just to say that Easy2Boot can now multiboot UEFI images. It even allows you to boot direct from MBR mode to UEFI mode without rebooting by using Clover.

Very nice Steve.  Yea!!

And does it work with flash drives that are configured as Fixed rather than Removable??

yes. If you make a .imgPTN file from a Windows Install ISO, you can run it from a USB HDD without needing a Helper Flash drive.