Sandisk Clip Sport won't turn on, charge, or reset

I was hiking with my Sandisk Clip Sport this morning with a 50% charge when it turned off halfway through a song. I tried resetting it and powering it on again but nothing happened. I had it plugged in to the wall charger, but nothing happened. When I tried resetting it by holding the power button for 30 seconds, the screen lit up but is blank (black). It stays like that until I hold the power button another 30 seconds and the backlight goes off. I won’t have access to a computer until Tuesday. I was going to try leaving it plugged in overnight to see if trickle charging will work. Any thoughts? Should I leave it charging with the backlight on or off? I bought it new three weeks ago.

• Remove any external card from the Clip Sport before performing firmware update
• Ensure your battery is > 50% full.
• Plug in your SanDisk Clip Sport to your computer.
• Download and save the upgrade.hex file linked above to a folder on your computer.
• Drag the file to the root directory of your SanDisk Clip Sport
• Disconnect the SanDisk Clip Sport and let the firmware update begin.
• Once it finishes doing its update, it will turn itself off.
• Turn the Clip Sport on, Select your language and region preference

I’ll try it, but I’m pretty sure it already has that firmware version.

Firmware is the software code that powers your Clip Sport. You can think of it as the operating system.

If there are any people who have actual solutions then I’m more willing to hear those. Thank you!

Re-installing the firmware might help. Being friendly, too.

This if the player will connect to the computer.

Another solution would be to re-format the memory.