Sandisk Clip Sport Plus is not recognized by Audible App-will not Activate device to play audiobooks

I searched on this board for other mentions of not being able to activate my new Sandisk Clip Sport Plus (32GB) to play audiobooks from Audible. However, I did not see any real resolutions yet. Here it is, almost 2022, and the problem is still a problem. I currently have firmware version 1.01.B202 right out of the box, new. This appears to be the newest firmware for this model Clip Sport Plus (CSP), from what I’ve seen on the Sandisk support site. When I connect the device to my computer, it recognizes it and opens a window in Windows Explorer to view the files. However, if I try Audible Manager (an older interface), it tells me my device is not compatible and will not let me activate it. If I copy the .aax files directly to the CSP, I can see the book on my device, but it tells me I must activate this device to play this title. I have contacted Audible and they had me install, then uninstall Audible Sync. It did not recognize my device, even though the computer (WIN10) does. Then they had me install Audible for Windows 10. Same thing, it will not recognize my CSP! Their tech forwarded me up to Audible’s Tier 3 help desk, and they do not yet have a resolution. I figure they will eventually refer me to Sandisk. So…here I am. ANY help is appreciated!

Hi @fixit630,

Please contact the SD Technical Support team for best assistance and troubleshooting:
https://kb.sandisk.com/app/ask

Hi @fixit360
I had the same problem recently, I contacted audible who where helpful but not able to fix the problem, also not helped in the fact they have dropped their Win10 App and now use something calle AudibleSync. I then googled the issue and found a solution posted by someone else.

The audible app 'appears ’ to only poll a few drive letter looking for the player, my problem was my palyer was E: try changing the drive letter to someting less for example A: B: or D: once I did this all was fine and am now able to authorised my player and sync correctly.

Thank you for the suggestion, Tonyn. I tried changing to drive letters A, B, then E, respectively and none of them were recognized by Audible’s apps. (Audible Sync or Audible for WIN10.) I already have a drive mapped to the letter D. I’m still waiting for Audible to get back to me.

Hi fix360, Sorry that didn’t work, have you ever had audible working on the device? I had but then it stopped, that’s when I found this fix. In case it helps here is the original solution I found via Google.

https://www.amazon.com/gp/customer-reviews/R3BOPGKXXVQ14R?ASIN=B00VXMY262

Tony

This is a brand new device. Received for Christmas, so no, it has never worked with Audible. Audible Manager says it’s not compatible. The odd part is, my old Sandisk does work with Audible Manager, but does not work with Audible Sync.

Thanks again for your help,
Gayle

Hi Gayle, Have been fiddling with Audible this weekend and noted the following.
I always download my books to an external SSD so that I always have access. Using the Win 10 audible app you were able to specify where downoads wre to be stored, however witg the new Audiblesync app you cannot, it seems to be fixed at your user aldata/roaming/audiblesync/downloads.
When I have my exisiting download library (SSD) attached and open AudibleSync my player is NOT recognised however if if detach my old library (SSD) and restart AudibleSync all works fine and the player is identified.
So I beleive that the app only allows 1 library location. I don’t know if the same is true for a library located anywhere else on the PC other tan a removable disc but it’s worth a try.
Also what I did was to download my book, copy to my external library and reimport into the old ‘and reliable’ Audible Manager which was a much better tool.
Good luck, let me know jhow it goes
Tony

Hi Tony,

Like you, I’ve spent WAY too much time trying (and failing) in my attempt to get my Sandisk Clip Sport Plus to activate in Audible – ANY app! (Audible for WIN10, Audible Sync and Audible Manager) Although I was able to get Audible for WIN10 to download a title to the new player, by designating that drive path, once the title is on the player, it says, “You must activate this device to play the title.”

I tried changing the drive letter that the Clip Sport maps when I plug it in. I even let my laptop update to Windows 11 to see if Audible Sync would work better under 11. (It DID NOT, and I DO NOT recommend WIN11! Too much functionality lost and extra clicks to accomplish a specific task…grrrrr! I rolled it back to WIN10.)

Audible says they’re still looking into the problem. How can I be the only Clip Sport Plus user with this problem??? I even looked into updating firmware (on a brand-new device), but it appears that the version I have is the newest. I have 1.01 firmware and B202 bluetooth. …sigh I’m really disappointed with Audible on this.

Thanks for hanging in there with me!

Gayle