SanDisk Clip+ problems!!

Hello :smiley: .

So…my cousin has a SanDisk Mp3 Clip+. She gave it to me in order to fix it. The problem was the fact that it wouldn’t turn on and when it was plugged on the laptop it wouldn’t open because she had to format it. I tried to, but it didn’t work, the error was the same all the time “Format couldn’t be completed” or something like that. Then I tried to reset it. I held the power button for 20-30 seconds, then I plugged it to the computer and it turned on. I let the mp3 to charge. When it was done, I removed it and turned it off. All seems well till now…but it’s not :))) now it won’t turn on…again. I don’t know what to do…so, could you please help me?

Thank you very much!! 

Sorry for my english…foreigner here :slight_smile:

How old is it? The battery could be wearing out. Did the battery show a full charge before disconnecting?

It never hurts to reload the firmware.

If you can get a computer connection, so you can see SANSA CLIP  in Windows Explorer (Computer or My Computer),  go to the firmware thread and reinstall the firmware with the Manual Update instructions. Basically, download the file, unzip it and drag the unzipped folder onto the SANSA CLIP driveletter.

I couldn’t put the folder in the Sansa Clip folder because when I plugged the mp3 to the PC I had the same error…it asked me to format it. So…in a desperate move…I held the power button while the mp3 was still plugged to the computer until the “Safely Remove Hardware” icon disapeared, then I pushed it again and it turned on. Now I delete everything from it and I’ll let it charge. What could this mean?

If you get the connection, reload the firmware and see if that fixes it.

How large is the unformatted disk you see in Windows?