Clip+ won't soft reset or turn on.

So, I have a new refurbished(from Newegg) 4GB Sansa Clip+. I bought it for my dad so he could listen to mp3s in the car, but today, he said that it’s not turning on.  He turned it on, and plugged it into the USB car charger, after that, it won’t turn on anymore.  I tried to soft reset it, holding down the power button for a few minutes.  Nothing.

I also tried holding down the center button while I plug it in, and it was recognized, but it said to “Format Removable Disk: F before using it” or something like that.  I have no idea what’s going on.

Can anyone help?

So… No one knows how to fix this? :confused:

Try pressing and holding the Home/Menu button a split-second after pressing the power button as you normally do to turn it on. This will sometimes wake it up.

Oh hey, that did the trick! thanks a ton.

That worked for me.  Once the logo appears, plug it in.

Thank you! I just bought an old new Clip+ two months ago on amazon and 

this happened to me two days after amazon’s warranty expired.  Sandisk

offers a year but no guarantee if you send it back they will replace or fix it.

And they won’t talk to audio customers on the phone.  

But your simple fix worked perfectly.  Thank you.