SanDisk backup software crashes - cannot backup

Dear all,

I own a SanDisk ulta backup 128GB stick which I have been using regularly to backup several folders on different computers, some password-protected, others not. Everything worked fine.

But now, the software crashes constantly. The backup windows does not appear anymore when I plug in the USB stick, and after double-clicking the <SanDiskBackup.exe> file on the stick, the software crashes.

I have already tried downloading the updated version of the software (2011-06-29), same result.

Any ideas?

Thank you,


Sorry to hear that. What happens when yuu open it through My Computer? Can you even see the USB stick drive or any error messages when trying to open it? 


Thanks for your reply.

The USB drive is fully functional, I can access all data on it. No error message, usual performance, that’s perfect.

The only issue is that the backup software does not work anymore. Neither automatically (as it used to) nor when I try starting it by hand.


nobody has got a clue?

hard to believe…

Altogether, that’s quite unsatisfactory: Your purchase decision for the stick is based on its backup capabilities, but then when it stops working, there is no remedy and it just won’t work from that time on…!?

That’s not how I expect a SanDisk product to perform!

Any suggestion is still appreciated.

@bluesea wrote:


nobody has got a clue?

hard to believe…


Not really, when you consider this is a user’s forum. We don’t have all the answers. Why don’t you call SanDisk Tech Support? They are not only trained, but paid to help customers with problems such as yourself.

And, if they can’t fix the problem for you and the device is under warranty they can arrange to replace it right then and there.

Ok, I’ll try contacting SanDisk, in that case.

I was not fully aware that this forum is not followed by SanDisk.

Thanks, Philip