SanDisk 64GB Micro SD shows up as 27.4 GB on Windows 7

Hello everyone!

Please help me out with this problem - I have looked everywhere and spoken to SanDisk support,

but no fix - you are my last hope! 

I have got a genuine SanDisk 64 GB Extreme Plus Micro SD card (U3 XC1).

I bought it for my GoPro 4 Silver edition. 

The problem is - when I insert card in my computer ( OS Windows 7 64bit ),

this window pops up:

I can’t access the card or see Properties, so I format my SD Card (it’s empty anyway, don’t care) - 

doesn’t matter what I use - Windows formatter or SDFromatter V4.0 (suggested by SanDisk support) -

it already shows up as 27.4 GB Micro SD card. 

Now - whichever way I format the card - it is working now and I can access it! 

But the problem is - it is now 27.4 GB Micro SD card…

Also when I insert the card in my GoPro 4 - it works fine, there is no SD ERR etc., BUT my filming time is reduced down from 4h to 2h. The card is recognised as 27.4 GB now…

Now what about formatting the card on my GoPro 4 ? 

Seems like a good idea - might work. 

Now it is 64 GB card, but once I insert it back to my Computer (OS Windows 7 64bit),

this pops up again (!!):

And there we go again…

SanDisk has offered to replace the card - they mark is as faulty,

but I believe this is OS problem - my computer clearly can’t read 64 GB Micro SD therefore formats it to 27.4 GB… 

Please help! What do I do?


in that case you can also try to format the card with the hp tools software that could allow you to select to format the card on exfat. 

you can download the software from here:

this is not a card problem. Since it formats back to 64Gb in the gopro the most likely culprit is the reader you are using with the computer. There may be a FW update for the reader but that is a long shot. You will probably need to bey a new reader that can support the SDXC cards. The SanDisk SDDR-280 USB 3.0 multi card reader is what I use and it works great. 

1 Like

I used the SD Card Formatter from Sandisk and it formatted my 64GB Micro to 58.27 GB.

Apologies for being late into this thread but I have the same problem. I formatted my 64gb micro SD card using the Sandisk formatter and it formatted to 59gb. Good enough. But when I put the card into my bullet cam it only shows as 27gb. Tried it several times same result. Any help greatly appreciated.