Micro SD XC sandisk 64Gb : only 27.5 Gb

Since a format I think, my sandisk 64Gb appears to be a 27.5Gb for my computer and my phone. When I try to format it or check partitions, the only capacity available is 27.5Gb and not 64Gb as before.

I tried with sd formatter, same problem

  1.  Are you sure it’s a genuine card and not one of the many fakes out there?
  2.  Did you format it as exFAT, the native format for 64GB cards?
  3.  Did you do a regular, or “quick” format of the card? A full format, not “quick” is better.
  4.  Did you try any other format programs besides the SD Formatter?
  5.  Have you tried calling SanDisk Tech Support/Customer Service? If it’s defective, they can replace it under waranty for you.
  1. I bought it on a website like amazon, or another reliable seller, and I had 64Gb before…

  2. I’ve already tested exFAT, but I can re-try

  3. I’ll try it

  4. I tried many software before SD formatter: the software of windows 7 for partitions, then EaseUs partition Master, then MiniTool Partition Wizard Home

  5. not yet, I’m not sure to have still paper of warranty

which software do you think I need to realize a new format of my microsd card in exFAT?

The SD formatter is the best format tool to use. You need to make sure your reader will support 64GB cards though. Some readers will cause this issue. 

1 Like