Rhapsody songs do not transfer to my Sansa Clip 2GB

I have searched the other threads and have tried their remedies, but to no avail.  I have updated the Clip’s firmware, loaded the latest Rhapsody, have Windows Media Play 11 installed on my XP desktop.  I have the Clip configured for MTP.  I have formatted the Clip using the firmware and have formatted the Clip with Rhapsody, authorized it with Rhapsody.  When I try to transfer a valid song (or even a playlist of just one song), it states that transfer for 1 of 1 song will take 21 sec, but no progress is show and the Clip is not updated with the song.  I have waited a minute or longer and the status remains.  Please help as I have spent twenty hours trying to get the players set up for my kids. 


First, check that your Sansa Clip is being recognized properly by the Rhapsody 4 client in MTP mode.

Open the R4 client.  Then plug in your Sansa Clip.

If it is in the proper mode, and your MTP system is OK, it will show up in the sources pane (upper left) as something like Sansa Clip 2GB , (depending upon whether it’s a 1,2,4, or 8GB device).  If the device identifies as something all in CAPITALS, with a drive letter, like E: SANSA CLIP , the device is seen in MSC mode.

MSC can be used for purchased tracks only, not “Rhapsody To Go” media.

If it is displaying in caps and smalls, right click on the device and select Authorize after signing in to Rhapsody.  As a quick test that all is well in the Rhapsody system, go to the Music Guide, select a track, and see that the track begins playing.

Look in the lower right corner after authorizing the Sansa, then clicking on the device (left button this time).  Do you see " licensed until 1/3/09" or something similar?  If so, drag and drop the currently playing track to the Clip.

Does the progress bar roll along at the bottom of the screen?  Please note that a WMDRM track will normally take 20-30 seconds to transfer, as it has an embedded leaf license.  This is normal; a DRM transfer from your hard drive as a protected file will take about the same time per track.  An unprotected mp3 file takes a few seconds in comparison.

If the track transfers, let’s do a quick test.  Once done, disconnect (click the disconnect button in the middle right of the “internal memory” pane that is visible when you click on the Sansa.)  Unplug, and the Clip should say “refreshing database”.  Go to Music and try playing your test song.  You can navigate to the Artist, the Album, or the Song title.

If it lists and plays, you’re ready to load that wee beastie up with your favorite music.

If the track would not transfer, let us know what is displayed in the Rhapsody window.

The simplest next step is to plug the Sansa back in, and let it pop up within the sources pane.  Right click, Deauthorize the device, then Authorize again.  It should be happy at this point.

Again, if you run into any issue at this point, please post your results.  We’ll get you up and running!

Bob  :smileyvery-happy:

I am running in MTP.  I perform the steps that you described and see those results.  Once I transfer the track, I see the line “Transferring 1 of 1 tracks to Sansa Clip 2GB.  Approximately 21 seconds remaining.”  Howevr, there is no “blue” progess bar in that line.  I have waited several minutes and the track never transfers.  Shortly after I initiate the track transfer, the word “Writing” shows up on the Sansa Clip (but that is the only time even if I have more than one track being transferred.  I installed Rhapsody through Verizon Wireless website.  I updated the firmware to “01.01.30A”.  I have used the Windows Explorer window to look at the Sansa Clip, but no tracks were loaded on it.  When I reconnected the Sansa Clip, R4 displays the message that nothing was found on it.  I also tried to deauthorize and authorize again to no avail.  When I disconnect the Sansa Clip using R4, the Sansa Clip displays: 1.  Disconnected; 2.  Refreshing database(progress bar moves).  3. “Your subscription has expired.  Connect to your PC.”.  Please let me know if there is any other info that I could provide to be helpful.

I think you can try reformatting the device.

Unplug the device.

Go to Settings>Format> Select Yes

Reconnet the device to Rhapsody and try to authorize it,  then license the device.

You should then try to drag a track to the player.

I tried your recommended solution, but I still have the same problem.  Is “Your subscription has expired.  Connect to your PC.” a clue to my problem?  This is always displayed after disconnecting my Clip.

I have the same problem for my clip on my desktop PC. Whenever I download songs on that PC I always get that error on my ‘Clip’  What I notice is that there is a date in the lower right of Rhapsody that say something like 2/14/2014.

I’ve tried everything to get rid of that date with no success. Formatted device, renewed, de-authorized and more.

I now only sync that device on my laptop.

I haven’t tried uninstalling Rhapsody however,

Good luck and let me know if you figure it out.

I am struggling with a similiar problem - I have doen all sorts of things to my Sansa clip and I just transferred 147 songs to it - now when I try to play a song I get the following message “Synchronize to continue your music subscription”???  This thing is driving me crazy and the Rhapsody people have not been able to help me as of yet with this issue!

I have had similar problems with my Sansa clip 4GB and spend time online with Rhapsody support to no avail with the first technician.  I had the subscription message first “renew in 5 days” and I formatted the device through my computer and on the device itself, updated the firmware, authorized and deauthorized, etc.  I was told to put the clip in usb mode “auto detect”.  When I formatted the device (which was not given by the tech) I was able to make the subscription message disappear, however after suffering through multiple defeats with my Verizon Blkberry and Rhapsody, a seperate tech told me how to reset the secure clock, which may work fr some of you?  Press shift + control together, then right click on the device in the sources column.  It should come up with “reset secure clock” and click on that.  If the laptop and the device don’t have the sync time, I guess they don’t cooperate.  This worked for my blkberry, but not so far for my clip.  The clip now has not subscription message but won’t transfer more than 2-13 songs then it stops.  The progress bar doesn’t move and the device changes from “writing” to “connected”.  I have found no solution in the past 24 hours, and I am thinking of returning it.  I have no patience for these “easy to use devices” when they malfunction to the point of paperweight and the techs can’t provide you any assistance!

I have a sansa clip and I wanted to ask- HOW CAN I PUT MUSIC WITHOUT RHAPSODY? I mean I have a windows XP desktop but it got messed up so I dont know if rhapsody will do something bad to my computer.:womanindifferent:…so can you help me? if you can please reach me at genesistrockz@hotmail.com 

No need to use Rhapsody. The easiest thing to do is just open up the Sansa Clip in Windows Explorer and then just drag-and-drop your music files to the player.  

The issue appears to be with corrupt Rhapsody software. I had the same problem, but after uninstalling Rhapsody and doing a CLEAN reinstall, I found that all the tracks that were previously “hanging” were tracks that are no longer available on Rhapsody, but weren’t originally highlighted as such until after the reinstall.

Here’s the page on performing a clean reinstall.

Hope it helps!

Ok im up to here with this thing! I have tried EVERY remedy i can find to get my clip to upload from rhapsody… Ive uninstalled, reinstalled, rhapsody, formatted clip, made sure its in the right mode, did the whole lock hold middle button as i connect to find drivers, nothing comes up even uninstalled and reinstalled WMP 11. I have vista 64 bit and this is about to make me nuts! i cant wait till i can just upload to my blackberry! soon right? thats what the site says…