Rhapsody Help w/ new 4g Clip

I bought a 4g Clip about 2 weeks ago. I updated the firmware and tried to download music from Rhapsody. When I try to do this the bar at the bottom says “Transferring 1 of 1 tracks to Sansa Clip 4GB Approximately 6 seconds remaining” but there’s no blue status bar to show that its actually transferring. It stayed at that message for about 10 mins. I figured something was wrong with the Clip so I went back and exchanged it for a new one but I’m having the same problem. I’ve tried looking at other messages on the forum but no help. I updated the firmware, updated my Rhapsody software & made sure its in MTP mode. I also I have a Sansa Fuze and a 1g Sansa Clip that works fine with Rhapsody so it must be something with this Clip. Anyone have any ideas on where to go from here?

Thanks for your help

Be sure to right click on the Clip, in the sources pand of the Rhapsody 4 client, and select Authorize.

If you haven’t done so, be sure to update Rhapsody to the newest client build, by going to Help > Check For Updates.  When updating, be sure that no devices are currently connected.

Oh, and that lingering blue progress bar?  I feel your pain.  Have a cup of coffee for that first transfer wait, and see if it completes successfully.  As soon as the file is located from the Rhapsody server, the individual tracks transfer at about 30 seconds per track.  As of late, I’ve also experienced quirky song transfers; hopefully, they’ll get it ironed out on their end.

The transfer speed is slowed by the wma DRM process, as the leaf license is embedded in the track.  Transferring a file directly from Windows Media Player takes a similar amount of time.

Bob :smileyvery-happy: