Reset Everything?

So here is the rundown, I was connected in MSC mode, deleting files. I got a “Error file not found” message in the middle of deleting a directory. I double check and the file was still there. I decided if i disconnect the Fuze and reconnect it, the file might not be there because sometimes windows is a little behind. So after disconnecting it starts refreshing the Music DB. Then I get the error message on the Fuze “Not enough space to refresh Music DB free up 90mb”. So I plug the Fuze back in, and get this message “Windows does not recognize the device” and the fuze powers on and i get the Music DB message again and windows never sees the Fuze. I have had this for a week now and everything was working great. Is there a way to nuke the Fuze through a combo of buttons on startup or is this just another defect.  Any help would be great!

You have a handy Nuke It function available on the device itself: the Format command.  This will erase everything but the firmware on the device- all of your music, photos, and video are removed, starting with a clean slate.

To do this, navigate to Settings > System Settings > Format > Yes.

Mushroom cloud time, fresh slate.

The Music DB error message may be caused by corrupted files on your device.  You can access the device in MSC mode, and run chkdsk on the Sansa drive, from the Run “box” of windows.  It’s a simple matter of getting to that command prompt, old school time. Once you locate the drive letter assignment for the device, let’s say it’s E.  The command will be chkdsk E: /f where the /f is a toggle allowing the computer to attempt repair of the files. 

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 06-19-2008 07:34 AM

Well thats the problem, I get the error message about the Music DB then the device shuts off, I tried holding the power button for 10 seconds to reset but this did nothing. On an older player, if i held certain buttons on startup it cleared everything from the player. Thats what I am looking for now. Also i can’t connect to my computer either. The player seems to be “bricked”.

So, basically, is your player dead? That sounds similar to what happened to mine a couple days ago (check my thread). On mine, got the dreaded “Not enough space to refresh Music DB free up 90mb”, and then nothing. No turn on, no recognize by Windows… Nothing. So back it went.

These things seem extraordinarily sensitive to what seems to users like very normal conditions, tossing out that ‘free up 90 mb’ prompt way too frequently in situations that dont make sense. In my case, I dont know how much pre loaded stuff comes on the player, but if a 400 song transfer to an 8gb Fuze can cause it to really overfill, then it comes with Way Way too much junk… I dont think I really overfilled it at all; I think the Fuze just abended with that as the message I saw.

Bob… u around? Whats the deal with this “Not enough space to refresh Music DB free up 90mb” msg, and why does it frequently seem to be seen just before a Sansa player abend? Workarounds?

BTW, in your instruction to reformat the device, how do we get back the preloaded stuff lost to the format if we want some of it? Is it available via download from the site, or, are we out of luck on that one?

Message Edited by boostm3 on 06-20-2008 06:21 AM

Morning, Boost!

Yep, in fact, I have a wee Fuze undergoing a medical experiment regarding your issue as we speak.  I’ll have a possible answer in a few.  I’m giving myself a coffee infusion, and the Fuze a data infusion.


Bob  :smileyvery-happy:

I’m back.  Lots of wee twirling Sansa logos here.  Let’s try a few things on the Fuze.

Starting with the power OFF (touch the center button to see if there’s any activity),  slide the power switch DOWN to the HOLD position, exposing the wee orange dot.

On your PC, open a Windows Explorer window (My Computer).

Hold the << side (9 O’clock position) of the scroll wheel / 4 way button down, while plugging in your Fuze.  Keep that button held down until she pops up on the PC.  A very good sign is if you see a pop up “Found New Hardware” balloon in the system tray.

Does the device show up in the open Windows Explorer window, in MSC mode, with a drive letter assigned now?  It will ID under devices with removable storage as SANSA FUZE ( E: ) all in capital letters.  At this point, you can indeed format the device by right clicking on it and a window will pop up starting with the correct FAT32 format mode.  Don’t try this quite yet.

First, let’s try fixing the reserved partition with a new copy of the firmware.  You mentioned that your Fuze wasn’t responding to the soft reset, meaning that it wouldn’t start up allowing you to use the preferable Settings > System Settings > Format command on the device.

Go to this thread, and download a copy of the 1.01.11 firmware.  I set the link to open in its own window, so this thread will still be available.

Download and install a new copy of the firmware as shown in that thread.  Be SURE to unzip the file prior to proceeding.  The extracted file will be 15,360 Kbytes, named fuzea.bin.  Shrink the Windows Explorer window a wee bit, so that you can easily drag and drop the fuzea.bin binary file into the root directory of the Fuze.  This is represented by the open Windows Explorer window; don’t drop the file into any of the visible folders, but into the main box, representing the root directory.

Once that’s done, the display will go from “writing” to “connected” on the Fuze, you can disconnect the device.  What we’re looking for is the message “firmware upgrade in progress” on the device.

Power up the Fuze, and select your language if that screen in active.  Then format the device by using the Fuze’s settings mode.

Let me know if this is successful.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 06-20-2008 07:17 AM

Hi Bob…  not to interrupt Cybermonk’s thread, just wanted to ask you,  does the process of updating our firmware cause a destructive write to any data on the machine, or, is the existing material on the fuze maintained in tact?  Im guessing that, unless our firmware update is part of an overall player refresh which includes a format of the device, the data files should be maintained in tact?

I’m guessing the Fuze works similarly to the e200, in which you can format during the firmware update process by including a blank file named sansa.fmt along with the firmware file.  Without the sansa.fmt file, the firmware update doesn’t delete any user content, such as music, photos, etc.  Of course, I could be wrong since my experience with this is limited to the e200 series.  I have a Fuze, but I haven’t updated the firmware on it or anything like that.

No difference in operation. When i plug it into my computer here is what happens. The sansa logo appears for about 30 secs followed by the “Not enough space for the Music DB” message, followed by the Connected with the spinning wheel. Windows pops up a Device not Recognized followed by the USB connected sound. I have tried removing the usb drivers for the player which did nothing, and i have tried connecting on 2 other machines. After unplugging the player it freezes at the “Connected” screen for about 10 seconds, then flashes the “Not Enough Space for the Music DB” message before powering off.

Turn off the player and set the hold switch

Press and hold the << key and connect to USB

Find the Sansa Fuze device,  on the PC and Right click and Format it.

unplug and now you should be able to boot it and reload content.

Set the USB mode to your preferred mode. 

Installing a new copy of the firmware does not erase the music and other media from your device.

EDIT: sansafix,  good morning!  You beat be to it.  In my earlier post, I wanted to hold off on a format from the PC in hopes of resurrecting your data.  Format the device from Windows Explorer and see how it goes! -Bob 

In this above case, it appears that there is a dual problem in that the device cannot be operated via the unit’s controls to format the troublesome data AND it can’t be accessed from the PC.

If you have one available, try a different 30 pin SanDisk USB cable.

Otherwise, perhaps we have a comm failure on the device. Call 1-800-SANDISK for a new Fuze.

Bob :cry:

Message Edited by neutron_bob on 06-20-2008 09:44 AM

The manual instructions say that a Reset is simply to reset factory settings… A Format on the oher hand trashes data… If we have to perform that destrutive operation, how do we reaquire  the songs and data that came on our Fuze from the factory? Since we paid for the installed music, Id think it would be available on the download list on the website, but I didnt see it… Ideas?

I reiterate, The device is not connecting to my PC because it is not recognized. I have tried other PC’s, I have held the << button upon plugging in. No drives appear, not even under XP’s Computer Management Console.

When the tech walked me through both the soft reset and the pressing the rewind part of the dial while making the usb connection with the hold button set and it still wasnt recognized and still wouldnt turn on, it had to go back for replacment.

Message Edited by boostm3 on 06-20-2008 11:30 AM

Just as a footnote, there are two “reset” operations, with slightly different results.

The soft reset is performed by holding the power switch in the ON position for 10 seconds.  This function performs a hardware reset, dropping the changes made during the last power ON session, and allows the device to restart if it hangs.  Your preferences are retained, as long as they were not changed during the very last session.

The menu reset is accessed from Settings > System Settings > Reset Factory Settings. This operation sets everything to the factory default options, such as USB mode, volume, brightness, backlight, power save, just as it was when first used.

Bob  :stuck_out_tongue: 

I know this topic is a bit dead :neutral_face: but a trick worked for me.

If your Fuze is not responding in any way; to resets, plug ins, blah blah blah, and there is nothing active about it at all, make sure there are no headphones or Mini SDs plugged in. 

I tried some of the above and messed with my Fuze for hours trying to get it working, even contemplated throwing it, until I just took the Mini SD out, and voila! It came back to life. And, btw, I reccomend having at least 100mb for “Refreshing your libray” because I got the error when I had 98megs free on my Fuse.


I have a Dell Laptop.  Two weeks ago, I plugged in my External Hard Drive. My computer didn’t recognize it.  Neither did any other (3) computers we had.  THe next day, I plugged in my son’s IPOD.  It worked for about 10 minutes then my computer didn’t recognize it either.  It wouldn’t turn on at all after that.  THen I plugged in my  Creative Zen and it still works, but no computer will recognize it.  Finally, my Fuze turned on for a minute tonight after I plugged it in to charge AND then it went blank and I can’t get it to do anything.  My computer (under device manager) won’t recognize it, it won’t turn on, and I have tried to soft reset, etc. I even went and bought a micro SD to see it that would boot it. 

My question is this…is there a virus or something that will wipe all of this out in a few weeks?  We are talking about 1000.00 worth of electrical equipment.  Not to mention my pictures, etc.  Any suggestions for the SANDISK?  Remember I have tried other computers.  Could my Dell “fry” the equipment? This is too big of a coincedence.  I am so upset right now I coud cry.

PS I am using VISTA. 

My 8MB Fuze was completely dead. Tried all the fixes listed. Read the trick about removing the Mini SD. I didn’t have a mini SD in so I figured I try it with one installed. Sure enough it powered up with no problems simply by installing the Mini SD. Go figure???