My Sansa Fuze does not work.

So I got this new Sansa Fuze yesterday. Today i was puttin in music with WMP and but the process stopped.  Then I received the message “Not enough space for music DB” error. The player just shut down.

Now I’m stuck, it does not want to turn on. I tried the reset thing, doesn’t do anything. The switch to MSC, doesn’t work either. When I plug it in my computer, It detects a USB drive and ask to format it. When I actually try to format it, it always failed. Alos it says my drive is only 4MB (I bought a 8GB). 

I am really angry rigth now that this brand new player doesnt work. I really needed a player and I don’t want to spend a lot for another one just few days after I bought this. What else can I do ?

First of all, you have a one-year warranty, so you don’t have to buy a new player. You can call 1-800-SANDISK for technical help. Or you can try the homegrown remedies below. A bad file got on there that is giving you the error. Formatting would be the surest way to remove it. If you can get into the menus, go to Settings/System Settings and roll all the way down to Format to format the player. Or if you can’t access the menus, try this. With the unit Off, slide the power switch down to click into Hold position. You’ll see an orange dot. Connect the USB cord to the computer. Open Windows Explorer (Computer or My Computer). Hold down the << side of the wheel and connect the USB cord. See if it pops up in Windows Explorer. Right-click on Sansa Fuze and Format (to FAT32) from your computer. Before you put more music on the Fuze, it would probably help to clean up the tags. People put all kinds of junk in the tags–the electronic labels in the files–that your computer can handle but your little Fuze cannot. A free program called mp3tag helps. mp3tag. When you install, let it add itself to context menus (an option while installing). Open mp3tag and in Tools/Options/Tags/Mpeg make the Write option ID3v2.3 ISO-8859-1. Go to the album you want to add to the Fuze, right-click on it, choose mp3tag, highlight all the files and Save, which will write the tags as ID3v2.3 ISO-8859-1, the Fuze’s favorite. Also look in Comments and see if anyone tried to stuff an encyclopedia in there. You can choose for all the Comments on the left side when you have things highlighted. Also look for weird characters–boxes, foreign lettering, etc.–and use your judgment about fixing or removing them.

The process takes a few seconds and solves a lot of problems.

1 Like

Thx for the try, but I just said that I can’t format it. I did the Hold position plugin thing. Nothing works.

Call the company. 1-800-SANDISK. It could just be defective.