8gb Sansa Fuze won't format

My Sansa Fuze 8gb won’t format (holding on button in on position) or let me delete any files.  It says it is formatting and when it is finished shows “no songs” etc., but when it re-starts, all of the files (songs, audiobooks, etc.) are back.  When I try to delete files, it says it is deleting them, but again when it re-starts all of the files are back.

Windows Media Player 11 will give message “player almost full” do you want to delete files?  I say yes, it acts like it is deleting them – they “disappear” only to reappear when it re-starts.

Also “stops responding” after supposedly deleting files.

It is also acting really slow – 5min to start; 5min to turn off; 5min to connect to the computer (first says usb isn’t recognized then finally recognizes it).

I’ve tried updating firmware by dragging fuzeA.bin to root folder and I get the message that I don’t have permission to access or change the files.  Auto update fails.

When I try to add any new files get the same “you don’t have permission” error.

Tried it on two different computers.

Is it possible that your player has somehow been set to  read only? Next time you connect it in MSC mode, look for that, and if read only is checked, then uncheck it. Don’t use Windows Media Player again with your player until you get this problem sorted out. Use Windows Explorer(right click on start, click on explore) to interact with the Fuze.

Run error checking in Windows. Select drive, right click,properties,tools,error checking.

Thanks for reply.  I don’t use WMP11; normally do everything through Explorer.  Only tried WMP11 because nothing else working.

In MSC mode, can see file folders, but says all are empty.  Folders are marked as read only (square inside of square).  When I clear the square and hit “apply” it acts like it is doing it.  When I re-check folder property folders, the square is again filled in.

Can’t find “read only” for whole sansa fuze – just get pie chart when click on “properties”

Ran error check in MSC mode.  When I do it with neither box checked (automatically fix problems, etc.) it acts like it is checking it and then ends.  When I try to check one or both of the boxes, I get an error saying it can’t run error check and disconnects the Sansa Fuze.

Contact Sandisk tech support.  


I am now seeing a folder icon with a lock on the top left of it in MTP mode.  All of my files are in the MTP mode.  Any ideas on how to get them unlocked?

Now that you’re in MTP, try un-checking Read Only again.

Otherwise, it’s going to depend on the files themselves. Where did they come from? 

If they’re visible in MTP, that’s how they were transferred. I smell trouble. 

If all you’re seeing is filenames, like 01-Beloved Artist-First Song, then you need to tell Windows not to Hide Extensions of Known Filetypes. Look in Windows Help for how to do that (via View in Windows Explorer, also known as  Computer or My Computer). If it says 01-Beloved Artist-First Song.mp3 or 01-Beloved Artist-First Song.wma, .mp3 or .wma is the filetype.

Did you rip CDs with Windows Media Player?  If so, to what format: .wma, mp3? The default in many versions of Windows Media Player is .wma with copy protection–and if copy-protected files are transferred to another computer, they just won’t play, because they haven’t had their digital-rights keys transferred with them. That may be why you are seeing a lock–I don’t know, since I won’t touch copy-protected files unless I’m wearing my HAZMAT suit. 

(You can change that setting in Rip Music in Windows Media Player–uncheck Add Copy Protection, or, better yet, change the format from .wma to .mp3 at good quality, like 192 kbps or above. No copy protection in .mp3 files.)

If you still have CDs or mp3s elsewhere, your easiest choice would be to Format the Sansa–erasing all your files, so make sure you have copies.

Connected to the computer, right-click on it and Format to FAT32, or (disconnected)  look under Settings/System Settings for Format and nuke it that way.  Then switch to MSC. Rip the CDs to mp3  and drag-and-drop files to it. 

MTP mode and Windows Media Player are necessary if you got files from places like Rhapsody To Go or Napster–they have copy-protection information that has to be transferred under deepest secrecy by Windows Media Player. If you’re stuck with those files, you’re going to have to use MTP, and you’re going to have to transfer them via WMP from the original computer, not just copy them. 

Otherwise, MSC and mp3 will eliminate a lot of these problems. 

Message Edited by Black-Rectangle on 11-27-2009 06:17 PM

All songs are free mp3’s, but I also have protected audiobooks downloaded from NetLibrary and Overdrive.

I’ve always just left the USB mode on “autodetect.”

Transferred songs via Explorer Drag and Drop; Audiobooks via NetLibrary Media Center and OverDrive Media Console.  Some Audiobooks mp3’s; most wma’s.

The problem is that it won’t let me format in the drive (I mistyped it in the original post, sorry – I didn’t mean reset --though I’ve tried that, too).

I’ve tried formatting in all 3 modes via system settings > format.  It says it is formatting and shows all songs and audiobooks deleted, but when it restarts and “refreshes the media” everything is there again.

I’ve also tried formatting in all 3 modes via Explorer.  It starts to format and then I get an error message that it can’t complete the format – both “quick format” and regular format.

In MTP mode, the “read only” in the properties box is greyed out, so I can’t check or uncheck it.

I don’t know what I did that showed the folder icons with the lock, but I’m just seeing the regular folders again, but still can’t add or delete.  When I try to add, it either says “do not have permission to add this item” or “cannot create this folder” or something like that.

It “deletes” things, but then stops responding and says connection has been lost.  When I unplug, restart, and finally get it reconnected all “deleted” files are back again!

I’ve been able to format and “start over” before, but not this time.

Is there a way to force it to format? Or ungrey the “read only” options?


Also, even though the “read only” is greyed out; it is not checked.  So maybe I don’t need to “ungrey” it?

Just figure out how to get it unlocked so it will format . . . ?

Auto Detect…don’t trust it.

Auto Detect is going to send you to MTP mode as long as you have WMP 10 or 11 installed.

Change it to MSC. It gets MTP out of the way. Then try to Format via Windows (right-click) to FAT32. I know you’ve tried, but give it another try.

In MSC mode, delete MTABLE.SYS. That’s the database/index. When you unplug it will rebuild it from whatever is actually in the unit. In case you are getting listings that aren’t actually there.

Your audiobooks–Overdrive  and NetLibrary–are going to need MTP. Switch it manually to MTP (not Auto Detect) when you need those, and only then. Send your music via MSC. 

I’m worried that something may be bad with your memory chip–that it’s just not being written, due to a bad connection or the chip going bad,  which would be a defect beyond software. I don’t know if you’re still under the one-year warranty, but if you are, and none of these fixes work, call 1-866-SANDISK about a replacement. After a year, you might just have to replace the thing, unless someone else has an idea. 

Message Edited by Black-Rectangle on 11-27-2009 11:10 PM

Thanks for your help.  It’s beyond the one-year warranty.

I’ve tried deleting the mtable.sys – it comes back the same.  Not sure if it is really deleting it or just saying it is (like everything else).  I’ve tried altering it and it won’t let me.  I keep getting the message that it has stopped responding (same when trying to format).

I will try formatting in MSC in Explorer again – though I have little hope of it working.

Right now, I’m letting the battery completely run down just to see if that will do anything – doubt it will, but I’ve tried everything else.

I can still listen to all of the songs and some of the audiobooks still play.  Microcards still work (so far.)

Thanks again.

So you tried connecting in mtp mode, unchecking the read only on files marked read only(try doing the one file at a time), then deleting those files? If you delete all the read only files, then you should be able to format the player.

In MTP mode, the “read only” selection is greyed out and not checked for each file.  When I look at the details, it says the mp3’s are not protected or ready only.

When I uncheck it for the folders in MSC mode (no files show up in MSC mode), hit “apply”, close the properties window, and open it back up, it is checked again.

I also tried to use the free SwissKnife format program, but it says the drive is write-protected and can’t format it. 

Anyone know how to get rid of the write-protect?

In mtp mode, have you tried deleting as many files as you can? That way you could isolate the problem files. Sometimes a file can’t be deleted if it is used by another application. In the past I had some files that could only be deleted from a DOS prompt.

I’ve tried deleting all files and just specific files – it says it deletes them, but disk usage stays the same and when fuze restarts all files are back.

Also, when I format on computer in Explorer in mtp mode it says it formats but disk usage stays the same (I.e., 7gb used; 1 gb free)

In Explorer, trying to format in msc mode stills says it can’t do it.  SwissKnife format program says it is write protected.

when do format in fuze (system settings > format) it shows no songs, no audiobooks, etc.; but in system settings > info usage is still the same (7gb used; 1 gb free) – tried to do it with usb set to autodetect, mtp, and msc – all the same.  When fuze refreshes, all files are back.

I’ve tried deleting, renaming, etc. MTABLE.SYS in msc mode in Explorer on computer, but computer won’t let me.  Usually says it can’t find the file or something – but it is still there or disappears and then reappears – same file – if I disconnect and reconnect fuze.

My Sansa Fuze 8gb won't format (holding on button in on position) or let me delete any files.


I didnt see anybody else mention this but holding the button in the on position doesnt format the player it just does a reset, like resetting your computer your stuff stays where its at but the system resets itself.


Have you tried running the ChkDsk utility in windows (MSC Mode)? Try that its possible the FAT is corrupted and your player just thinks its full and this might fix it. 


Outside of that I would try to return it, you may have gotten a bad unit. 

Thanks.  The formatting/holding on button thing in my original message was a typo.

I have tried all kinds of things – nothing seems to work.

Formatting via Explorer:

In MTP mode it either acts like it does it, but doesn’t change anything or I acts like it does it, but in the end says it can’t be completed.

In MSC mode, I get the write protect error.

Formatting via player (system settings > format) – the “formatting” screen comes up and supposedly formats it (no files/titles show up under songs, albums, artists, audiobooks, etc.) but when go to system settings > info it still says 7gb/1gb free.  Then when it refreshes all titles are back.

Chkdsk either doesn’t come with anything (acts like it runs, but just disappears with no message at end) or comes up with the message that it can’t run chkdsk.

My fuze is a year-and-a-half old, so I can’t return it.

Perhaps the flash memory in the player has become defective? Can you at least play music from card memory? Perhaps it is best to ignore the internal memory and play songs from a memory card?