Recording Problem, both Radio and Voice

I have had my Clip+ for only a few weeks. I have found a problem with recording both the FM radio and voice. When I listen to the recordings, the audio is continuous, but there are little bits of audio missing (several tens of second). This happens fairly randomly, but I would say that it occurs on average once every minute or two.  I know it is not a playback problem since I can copy the WAV file of the recording to my computer and play it there. The same bits of audio are missing in exactly the same places. BTW, I am running the firmware revision that it came with from the factory, V01.02.17A.

You should update the firmware. Seems to me this was fixed in an update.

This link is to that latest one, but I think the issue was fixed in an earlier release. This latest version has all the fixes and enhancements included from earlier releases.

Tapeworm – No joy here trying to update my music player. BTW, I am still running Windows XP (that will change soon).

I first tried to update manually. I was able to download and extract the file (clppa.bin, 15 MB long, dated 5/17/2012). However, when I tried to drag and drop it to the root directory of my Sansa Clip+ using Windows File Explorer, it would not allow the file to go to the root. It would not allow it to go to ‘Internal Memory’. I can copy the file into any of the folders under ‘Internal Memory’ such as ‘Albums’, ‘Playlists’, ‘Podcasts’, but that will do me no good there (except for keeping a spare copy of the operating system).

OK, on to Plan B. Let’s do it the ‘easy way’. I attempted to install the ‘Sansa Updater’ on my computer. It download fine, and then it started the installation process:

Checking Internet Connection: OK

Checking Windows Type: OK

Downloading latest Sansa Updater: OK

Installing Sansa Updater: OK

Registering Sansa Updater: OK

Launching Sansa Dispatcher: Not OK.

The last step produced an error message: ‘The Installation failed. Please try again later.’

I did try again later, with the same results.

Any ideas?

I changed the USB mode to MSC, and the firmware downloaded OK.

Now, let me see if the recording problem is fixed.

I checked to make sure that firmware update is installed on the player. It is.

However, the recording problem continues the same as before.

Any more ideas?