ReadyCache SSD not loving Alienware?? Please help because so far this is total garbage!!

I know it’s there, my BIOS knows it’s there, Windows ‘Disk Managment’ knows it’s there, and yet the Expresscache software says …

“ExpressCache did not find any ReadyCache devices on the machine. Install ReadyCache device first and then start ExpressCache install again. Setup will now exit”

I meet all the listed system requirments and then some, This is a 3 month old Alienware Aurora R4, the BIOS is set to AHCI not RAID.

I’ve tried converting it to a GPT Disk, also an MBR Disk, it’s not formatted, it’s there as a basic disk with 29.82GB capacity.

It’s meant to be simple to instal and it’s a total waste of time and money so far. Please advise.

Thank you


What SATA driver are you using? There was someone else here that had the same error when they tried using the Intel RST SATA driver version 11.6. They had to roll back to Intel RST SATA driver 11.2 before expresscahce would see the drive. 

Thanks for the quick reply:-)

According to device manager …

Intel C600 series SATA AHCI Controller

Driver date: 12/10/2011

Driver Version:

How to change this thought maybe an issue for me personally.

Also something I shouldn’t have to do if Sandisk did their job properly perhaps?

you can download the 11.2 Intel RST driver here

11.6 was just released about a month ago so they didnt really ahve a chance to test it.