Cannot install Expresscache

When I try to install the Expresscache software, a pop up occurs that says Readycache device does not exist. The program then says system has not restarted after uninstalling Expresscache. I have verified the drive is plugged in correctly, is shown in the device manager and in the BIOS, the sata port is enabled in the BIOS, and I tried installing after deleting the expresscache file in programfiles(x86) and restarting. Expresscache was working before this until the SATA cable became loose and that the Expresscache software to stop detecting it. Once I fixed the connection, the software was still unable to detect the device despite it being shown in device manager. How do I get this back working again?

This may help 

In my post I said I have done all of the things mentioned in the post you linked. Still does not work. If it helps many of the registry values don’t let me delete them but they mostly refer to a cruzer flash drive.

I am having the same error, it seems. I took screenshots of the exact error.

This is following a long sequence of other difficulties that this product suddenly brought on me after working fine for 3 months.