Problems again

I was away on vacation and when I returned I went to use my clip.  I got the dreaded connect to your PC to Syncronize to your PC notice.

So I tried to update the license.  Nothing, I did a reset, I did a format, I did a slide down side button, hold center and connect to the computer, nothing.  I deauthorized my computer and re-authorized again, I uninstalled Rhapsody and re-installed. 

When I connect the clip and it shows up in the sources pane it says its licensed until 9/15/2008.  I have basically tried everything and anything I have learned from this forum and no good.  I am really at a loss and very disappointed.  I miss my clip!! 

Can anyone help?? 

p.s.  I also have the newest firmware and have confirmed this on the clip.  I also have the latest version of Rhapsody (at least my computer says that when I hit update)


Message Edited by bby31288 on 08-12-2008 02:38 PM

Did you try to format the device using its own format command under settings>Format

Deauthorize the device , deauthorize the computer,  reinstall rhapsody,  Authorize computer, Authorize the device.