Issue with new Clip + using Rhapsody

Hello.  I have recently purchased a 4 gb clip plus and have downloaded songs from my Rhapsody library.  After I play a few songs, and turn it back on, I get the message “your subscription stracks have expired.  Connect to your pc to renew”.  When I try to play any of the tracks, it then says “Synchronize to continue your music subscription” 

You plug it in, and it writes and updates and then it will play.  Do you have to do this every time you want to use it?  I had a regular Clip (which was stolen) and but you didn’t have to constantly plug it in to the computer to get it to play.  I have done everything in Rhapsody that needs to be done, and it tells me I should have to plug in once a month.    What is the deal?

is the date and time set correctly on the clip+?

Sounds like the WMDRM secure clock is the issue.

There are two ways to synchronize the clock using the Rhapsody 4 client.  Well, there’s a third, but it isn’t as consistent.

First, the most basic: open the client and plug in your Sansa.  Then be sure to log in.  The client should read the license and track data and update automatically.  If you click on the Sansa, the license date should show in the lower right corner.

Next, ignore that goofball “license” button.  I think that it was simply designed to make the “licenses updated successfully” message pop up on the status bar only.  Whether it updates the Sansa is subject to relative humidity, the barometer being above 997mb, and the solar wind being below 6.2 protons per cubic meter.  So, deauthorize then authorize the Sansa by right clicking on the device in the sources pane of the Rhapsody client.

Lastly, I’ll show you the secret handshake, but remember, once I show you, the RealNetworks black helicopter may be sighted buzzing nearby.  Hold the [control] + [shift] keys depressed, move your mouse over the Sansa, and right-click on it.  Ah, yes, it’s a case of computer Twister for your clicking pleasure!  Reset Secure Clock will be an available option.

Oh, as all roads lead to Rome, you can also force an update by dragging and dropping a single song track from the library or Music Guide, over to the Sansa.  This will start the update process as well.

Bob  :smileyvery-happy:

Hello.   thanks for your reply.  Yes  the time is set correctly.


Neutron_Bob - thanks very much for you tips, I have tried all of them but the problem still  exists.  For example, I tried you last tip to drag a new track to the unit, which I did tonite, then I went for my evening run.  When i got to the park, i got that ‘your subscription has expired’ message, along with the direction to syncronzie with Rhapsodie.  

i am going throught the users manual now to see if there is any fix listed there.

Again, my thanks for your help.


Sporadic issues with the “synchronize to continue your subscription” flag can be rooted in the licenses themselves, or in the device’s secure clock itself.

The first thing to try is reinstalling the Clip’s firmware.  The problem is, the Clip + has not had any updates to the firmware yet (Important note to add to my “to do” list), thus no available base firmware to reinstall as this point.

It’s possble that you may have a hardware issue with the secure clock itself.

I would contact Support at 1-866-SanDisk during the week for further assistance with this issue.  They may be able to provide you with a fresh copy of the firmware.  The original release build is 01.01.05.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 10-04-2009 09:58 PM