Problem with 32GB cruzer flash drive

Hi all,

I recently created a ubuntu USB-HDD with persistence on a 32GB cruzer USB flash drive.

The installation went fine, the OS booted and it was saving changes.  I proceeded to install all the recommended upgrades as well as many packages I wanted.  I had a warning that the device was running out of space.

It was partitioned with 2GB (FAT32) for the OS and the remaining 30 for persistence (ETX2) (where all the data and changes are written to)

I used Gparted to remove the persistent partition, so I could extend the main OS partition.  Once I had done that, I recreated the persistent partition.  That had made the flash disk unbootable.  No problem I thought, I could just start again.

However I was wrong.  I am unable to format the drive now at all.  I keep getting an error saying it’s write protected.  I’ve tried windows vista, win7 and Linux to try format it.  Ive used the HP disk tool, Gparted and Fdisk under linux.  Even dd under linux doesnt work.  

Is there someway I can force write protection off?  Or use a tool to brute force format it?

 There is no hardware switch on the device for switching write protect on or off.  I fear I might have permanently damaged the drive.  Any help?


Just to add, I’ve tried the registry trick too, with no luck

Any help?”

There is no fix for this problem.  Return it to SanDisk for a replacement.

Right ok.  So it’s a manufacturing fault?   I assume this will be addressed with future devices?

San disk don´t have a replacement in my country, Argentina.

How do I ask for it?

My Cruzer Blade, 32 Gb, shows that it´s write protect, so it is useless.

Can you help me? Its a fault of San Disk products as far I could see. Do you repair it? Can I believe in San Disk products?