Pen drive Cruzer fit 16 GB - Write protectd

Dear Team,

I have recently purchased a small 16gb pen drive and i have copied around 13 GB data in to it for the purpose of transferring from one computer another. During copying (Cut Paste) from pen drive to my computer  i have poped up a message disk write protected.

Following activities has been carried;

  1. Format - Not working in Normal and Safe modes

  2. Virus Scanned with latest upates - Not solved

  3. Registry created “WriteProtecte” and made its value to “0” - Not solved

  4. Executed below commad and result

D:\>attrib r:*.*

A   H        R:\autorun.inf

A            R:\RunClubSanDisk.exe

A            R:\RunSanDiskSecureAccess_Win.exe

From the above result i could not able to delete since the drive is write protected.

Please help me to get out from this issue.



I bought Pen drive Cruzer fit 16 GB recently but its not working properly. It showed popup media is Write protectd. I tried for format , its not working. Please solve my my problem.

Return it . . . either to your dealer you bought it from or SanDisk directly.

Is that the only solution? Return it for anther that will probably do the same thing down the road? How about an actual solution?

This is a known hardware error and can’t be fixed. Sandisk is aware of the issue, although there is no official recall for the product. This is an offical answer if you contact customer service:

"I understand that you are getting write protection error while accessing your Cruzer flash drive. The flash drive has detected a potential fault and has become write protected to prevent data loss. There is no method to fix this. You will need to backup your data and replace the flash drive.

Our team of developers is in combination with the OS developers looking into a solution to resolve this issue.

Please note that only a minor percentage of users are experiencing the write protection issue and these are the customers posting on the internet to find a solution."

SOLUTION 1: Return to where you bought and get a refund (as others usb drives might have the same issue)

SOLUTION 2: Contact Sandisk costumer service and get a refund, for the same reasons