Problem to reconnect under linux FW29

Hello Sansa community.

I’ve just bought a sansa clip :slight_smile:

And test it under linux (I’ve upgrade under win to fw29)

So here is the problem:

When i boot under linux with my clip into an usb port (with enough power) the system will recognize it and I can mount as a portable device.

But if I unmount it and try to reconnect nothing happen.

I’ve tried an other linus system (last Sidux in live CD mode, kenel 2.6.24.4) the problem is the same.

I’m now under Ubuntu 8.04 (kernel 2.6.24.13).

I’ve also tried to format the player under windows with FAT32 fileformat, same as before.

I’ve not tried with an other firmware but I’ll do it and edit this post if it works. (Fw20)

Here is my kernel log when i reput the sansa after unmount and disconnect it:

So Sansa works when I boot wit.

But if unmount / disconnect it’s no more recognized

replug:

May 24 18:30:14 UBU kernel: [2627.739873] usb 4-1: new high speed USB device using ehci_hcd and address 13
May 24 18:30:17 UBU kernel: [2631.260521] ehci_hcd 0000:00:1d.7: port 1 reset error -110
May 24 18:30:17 UBU kernel: [2631.260531] hub 4-0:1.0: hub_port_status failed (err = -32)

and rereplug :slight_smile:

May 24 18:32:54 UBU kernel: [2787.853112] usb 4-1: new high speed USB device using ehci_hcd and address 14
May 24 18:32:55 UBU kernel: [2789.001045] ehci_hcd 0000:00:1d.7: port 1 reset error -110
May 24 18:32:55 UBU kernel: [2789.001180] hub 4-0:1.0: hub_port_status failed (err = -32)

Under windows not any problem it works perfectly (MSC mode used)

I’ve decided to post here because it could be a firmware bug.

Thanks for your reading and help.

Edit:

After a test under ubuntu Gutsy and mint (7.10) kernel 2.6.22 it works like a charm. I think there is a problem with the fw29 by communicating with new linux 2.6.24 kernel. 

Message Edited by alastor666 on 05-24-2008 03:35 PM

Same problem for me using opensuse 10.2 updated with kernel 2.6.24: as workaround after pluging my clip a remove the module ehci_hcd using “sudo modprobe -r ehci_hcd” – Nothingman

Hello nothingman, ok i’ll try this if I turn back to .24 ^^

Thank for the tips, for the moment I’m running under ubuntu Gusty and Mint (7.10)

Message Edited by alastor666 on 05-25-2008 02:32 PM

I was having similar problems with other usb devices and I solved it on both Ubuntu and PCLinuxOS.  I don’t recall what I had to do, though.  I suggest you post a question to the Ubuntu forum.  They are usually quite helpful.

After upgrading to firmware .21, the device will no longer mount under Fedora 7 (Linux Kernel 2.6.23.17-88.fc7) but has no problem with Fedora 5.  Downgraded to .20 and it mounts under both 7 and 5 now although it requires several attempts occassionally.

Observing the device screen during connection attempts, if the depleted portion of the battery icon is flashing, the device is mounted properly.  Otherwise, the device must be disconnetd and reconnected.

During failed connection attempts, the battery icon goes to “steady on” immediately after the device displays “writting” and “connected”.  During a normal connection the battery icon flashes several times and then goes steady with the depleted portion flashing to indicate the device is recharging.

Possible a marginal power condition? 

same problem for me using Ubuntu EEE, Ubuntu 8.04, kernel 2.6.24-21-eeepc, with sansa clip silver (4GB). also indicator of battery matches with what’s been noted here already.

plugged in while booting: works, clip is also charging

unmounting and replugging: doesn’t work. clip is not charging

  then  sudo modprobe -r ehci_hcd : works, clip charging again.

no clue what the above code means. Would it be possible to adapt something so it works permanently? Appearently the problem lies there?

 anyways, thanx Nothingman