Trouble with Linux Sabayon and my Sansa clip 2gb

Okey, to get started with my “problem”. I’m using Linux Sabayon on my computer because it feels smooth and handy. Now, when I applied my Sansa Clip with the USB-cable it keeps toggling Connected/Connection Interrupted/ and to the original menu screen on the Sansa Clip display. Not even a connected unit is shown in linux :/. Even if I configure the “USB-Mode” options in my Sansa Clip it keeps acting like this, or well… when I picked the “Auto Detect” or the “MSC” option. When I picked the “MTP” option, it keeps saying “Connected” and toggling to the Sandisk Logo, but still, no Unit seems to be connected according to linux. Please help me out here guys, a Mp3 player without music is crap.

Toggling between the Sandisk and connected diplays is normal.  I have never seen the “Connection Interrupted” screen, though. Have you looked in /var/log/messages after connecing the clip.  One way to look is, as root, do ‘tail -f /var/log/messages’ before plugging the clip in. Here’s a normal sequence from Fedora Core 4:

Feb  1 17:25:16 polgara kernel: usb 1-1.3: new full speed USB device using uhci\_hcd and address 38 Feb  1 17:25:17 polgara kernel: usb 1-1.3: new full speed USB device using uhci\_hcd and address 39 Feb  1 17:25:17 polgara kernel: scsi8 : SCSI emulation for USB Mass Storage devices Feb  1 17:25:22 polgara kernel:   Vendor: SanDisk   Model: Sansa Clip 2GB    Rev: v01. Feb  1 17:25:22 polgara kernel:   Type:   Direct-Access                      ANSI SCSI revision: 00 Feb  1 17:25:22 polgara kernel: SCSI device sda: 3992576 512-byte hdwr sectors (2044 MB) Feb  1 17:25:22 polgara kernel: sda: Write Protect is off Feb  1 17:25:22 polgara kernel: sda: assuming drive cache: write through Feb  1 17:25:22 polgara kernel: SCSI device sda: 3992576 512-byte hdwr sectors (2044 MB) Feb  1 17:25:22 polgara kernel: sda: Write Protect is off Feb  1 17:25:22 polgara kernel: sda: assuming drive cache: write through Feb  1 17:25:22 polgara kernel:  sda: unknown partition table Feb  1 17:25:22 polgara kernel: Attached scsi removable disk sda at scsi8, channel 0, id 0, lun 0 Feb  1 17:25:22 polgara scsi.agent[24819]: disk at /devices/pci0000:00/0000:00:07.2/usb1/1-1/1-1.3/1-1.3:1.0/host8/target8:0:0/8:0:0:0 Feb  1 17:25:23 polgara fstab-sync[24838]: added mount point /media/SANSA\_M350 for /dev/sda

I don’t know why some of those messages appear to be repeated. Hmmmm.

Robert

In the MSC mode your Clip should appear as any other USB flash drive.

  1. Do you have problems with other USB flash drives using Sabayon?
  2. Have you tried a different USB cable?
  3. Have you verified your Clip does work with a Windows computer?

Message Edited by firefly on 02-01-2008 04:33 PM

  1. No I don’t, My Mobile works fine for example. 2. Yes I tried another USB cable which i had for my old Sandisk, it worked as intended before and should work just fine now aswell. 3. No I haven’t. (Making a check-up here!)

I just tried my Clip with the live editions of Ubuntu Gutsy and PCLinuxOS. Both recognized the clip as a flash drive when it was plugged into a USB port. The Clip displayed a short “writing” and then alternated between “connected” and the Sansa logo. PCLinuxOS played an MP3 file located on the Clip but Ubuntu lacked the MP3 decoder.

Does fdisk -l from a console list the drive? Maybe you need to manually mount it in Sabayon.

Mate, Could you check what USB “Option” you use in your sansa clip? still, i’m gonna see if I can mount the clip manually. (thanks for the advice).

The “problem” is solved! I couldn’t really launch the clip manually in Sabayon, so I decided to try my clip with my sister’s windows computer (as someone told me to do earlier in this thread). Well, it worked fine, I wasn’t that surprised really, but then, I went to my own computer again, and instead of sticking the Clip USB-Cable into my “USB cube” (as I have on my desk, with 4 sticks for 4 Equal USB-Cables), then I did insert the Cable in the back of my computer instead, and it worked fine! Thanks for your help anyways guys! (although, if I should’ve tried this from the start, then you shouldn’t have wasted your time on this thread :/).