Podcast issues

I recently switched from a clip+ to the clip sport and have found the Podcast functionality working incorrectly. Specifically with file ordering and it returning to the correct file when I resume an artist/album later.

For example:

I have 6 files:

41.mp3, 42.mp3, 43.mp3, 44.mp3, 45.mp3 and 46.mp3.

They have the following id3 tags:

{ Genre = Podcast, Album = RollPlay, Artist = RollPlay, Title = {same as filename, without .mp3}}

When I copy the files to the clip sport, they appear in it’s menu in this order: 44,41,42,45,43,46

When remove them, unplug the device, then plug th edevice back in and copy them again I get them in this order: 43,42,45,46,44,41.

How can I get them in the correct order?

The other issue I’ve found is when I resume a podcast:

 Let say I’m listening to podcast 43 (I’m halfway through).  I then start listening to a different podcast altogether, say startalk instead of rollplay.  when I go back into the rollplay area in ‘PODCASTS’ it starts with the top podcast instead of th eone I was listening to.  I suspect this is a sideeffect of the position being saved in a ‘POS’ file instead of in a more global place (a perfect name it seems)

Is there anything I can do to resolve this? (Anything other than returning this playing and getting something else?)

Are you using the folder menu or podcast menu to access the files? In folder mode the Sport lists the files in the order they where added to it and dosen’t use the id3 tags for file sorting purposes. If the files are removed and then copied again they might be transferred in a slightly different order which would explain the differences. You can use a utility such as FAT Sorter to adress this.

If you use the Podcast menu to access the files the id3 tags are however used for file sorting and the Sport will try to organize the content in a somewhat logical order. The id3 tags you are using should work flawlessly though and I haven’t been able to recreate the problem but you could try to add the title as track number as well and see if that makes any difference. If not, verify that you are using the latest firmware (1.22).

Regarding the second issue you are correct: This is a sideeffect of the position being saved in a ‘POS’ file for each track and a limitation of the Sport. Unfortunately there’s is no workaround available.

I did reset my device and install the latest firmware.

In the folder menu I do see the files in filename order.  although the .POS files are inbetween each mp3 file. (Thus I do not believe this is showing it in order they were copied.  It altually appears to be sorting it alphabetically)

Is the folder system how one listens to podcasts? (Instead of the podcast tool?) 

EDIT: I ask because in the folder menu you can’t resume fileplayback (It seems to ignore the POS file)

I’ve also tried to use fatsort.  As far as I can tell nothing changes to the file listing order.  How exactly do you solve the issue with this?

FAT Sorter works at file system level and makes a difference in folder mode only. If the files already are in alphabetically order it has no effect.

I would say the extended functionality of the database mode (e.g. Podcast view) makes it the preferred choice most of the time but the simplicity of the folder view has it strenghts too. In this case, using folder view would certainly be a workaround but as you have noticed there is no resume functionality.

I have tested some sample files on the Sport with the file names 41.mp3, 42.mp3, 43.mp3, 44.mp3, 45.mp3 and 46.mp3. ID3 tags: Genre = Podcast, Album = RollPlay, Artist = RollPlay, Title = same as filename, without .mp3.

They are all listed in the correct order. If your player runs firmware 1.22 (the original firmware lacks track number sorting using ID3 tags) and adding track numbers to the ID3 tag as suggested earlier (use version ID3v2.3) makes no difference, would it be possible for you to put a few files with the problem on dropbox and post a link so we can look at them?

In many ways this issue reminds of this one. Unfortunately a solution was not found: 


Here is the latest batch I encoded.  They’re showing in the incorrect order to.

they’re on the clip in the following directory:



Got a new clip+.  The files work fine on it.

I’m thinking the sport just has junky firmware

Indeed, it is a “challenged child” . . . .

I’m glad to hear it worked well with the Clip+. Yesterday I tested the files on a couple of Clip Sports but didn’t succeed in reproducing the problem. They all lists in proper order (RP-07-1.mp3, RP-07-2.mp3, RP-07-3.mp3, RP-07-4.mp3, RP-07-5.mp3, RP-07-6.mp3).

All the files have a empty track number field though so one thing you can do (if not already tested) is to add a track number to each file (01 for RP-07-1.mp3, 02 for RP-07-2.mp3, 03 for RP-07-3.mp3 and so on). In my experience this often helps.

I think you are correct about the firmware though. Perhaps it’s not the best example of good engineering…

I stumbled to a solution to the issue of the files coming up in the order they are suppose to be. Also was getting the files all jumbled and not following the order of the files sometimes which I created for files that this wasn’t labelled.

The solution that I found was to remove the # of the file and leave it blank. Without this it sorts the files alphatecially. Then I could just title the file to show up in the order that the files are by numbering them in the title 01, 02, 03, etc. I actually put the date so it labled 425,426 and it shows up in the right order. So the ordering of the files still doesn’t work work properly but if you get rid of this it will file the files alphatecially and numberically in the proper sequence not having this.

So yes getting rid of the track #'s for my podcasts works and the order doesn’t get jumbled and comes up in the order that I want. As it then does sort numeric and then alphabetic.

For radio podcasts that I download it actually saves time as to begin with it doesn’t have to track # and use to add them when using the zip. But when I have files that do have track #'s (listening to a lesson guide to learn another langauge)  I have to delete them which takes more time.