Sansa clip sport BOOK sorting is broken (v1.17)

Audiobooks sorting does not work. Plain and simple. The problem occurs on both stock firmware (1.09) and latest 1.17.

I’ve already tried:

  • sorting by filename (all files named aftery track number: 01-38),

  • sorting by TITLE tag (set via mp3tag tool, using track number),

  • sorting via track number,

  • deleting AUDBOOK.LIB.

  • generating m3u file in Windows Media Player and moving it into the folder.

No of the above steps give any result. No sorting whatsoever. I’ve had many models of Sansa Clip (normal, plus, zip) over the years and I’ve been listening to tens of books (so I know how to set tags etc.) and this is the first time I have such problem. Audiobooks sold in my country are all in mp3 format, so I can’t use audible (whatever it is).

Using FOLDER funcionality is not an option because it skips tracks (go to the previous one) when you press back button instead of going back to the beginning of the track.

Please let me know how can I sort them. I’ve already spent hours trying to fix it. This is really frustraiting.

The audiobooks I have sort correctly. Can you put a few files with the problem on dropbox and post a link so we can look at them?

1 Like

out of order example

I’ve got the files named in order 01-24, the tags titled 01-24, and the track numbers 01-24, yet it shows up in pretty much any order but 01-24.  Be interested to know why.


thank you mettrodome, for posting the files. This is the exact same problem I have. I’ve already tried 6 different audiobooks (with tags, numbers, proper filenames) and none of them is sorted correctly.

I hope the fix for this issue will come soon :cry:

I downloaded the files linked, there are 33 files and I copyied them via drag and drop without makeing any changes to my clip sport running FW 1.17 and all 33 files show in the correct order. 

How did you copy the files? Did you sue some software to sync the files or drag and drop? Were all the files added at one time or did you copy some then later copy more? 

I select all of the files at once, drag and drop, using Windows xp.  Is it sorting by when the files are added? I suppose it may be finishing some of the smaller files sooner.

I’ve just checked files uploaded by mettrodome and as expected have the same problem with them. Here is the order: 03, 02,05,06,07,08,10,11,12,21 and so forth. Please mettrodome check if you have the same order, maybe it will be helpfull for Sandisk team finding where the problem lays.

And here is how I moved the files to the player:

  • extracted them with winrar,

  • copied the “Emberverse 6-Sword of the Lady” folder (ctrl+c),

  • paste whole folder into G:/Audiobooks (ctrl+v, internal mp3 player memory),

  • safe remove USB device.

In other words simple drag and drop in windows explorer. No dditional applications. I’m using Windows 7, so it is not releted to XP.

I had the same problem on stock 0.9 firmware, so it is not a bug only on 1.17. Restoring default settings and formatting the memory does not fix it.

that is really strange. I did basically the exact thing you did and the files are sorted correctly. can anyone else recreate the issue? if not maybe contact sandisk support and see about getting a replacement. 

@mettrodome wrote:

 Is it sorting by when the files are added? 

From what i understand the audiobook menu should sort based off ID3 tag however in the folder menu the files are listed based off the FAT and if files are copied in different sessions the files added in the latter sessions will be added to the end of the list. 

I should have mentioned, I do have v1.17.

Mine goes:

10-24,33, 27,32,2,3,28,25,26,4,29,6,8,7,30,1,9,5,31.

Then for giggles, I took it off and reloaded it again.  This time:


I doubt this helps clear anything up, but that’s what it’s doing with pretty much anything I put on there.

1 Like

can you try formatting the sport, set it to factory default,s and reload the FW? other than that i dont think there is really anything else you could try. I tested your files and they are sorted correctly for me so if the above does not work maybe contact sandisk support and see if you can get it replaced. 

I tried reformatting and resetting back to the factory settings and now I’m able to get it to show up in this order:

3,2,5-12,21-33,4,17,19,14,15,1,16,13,9,18,20 which seems like what Swit was getting.  Still not right, but at least it’s something like what someone else got, so maybe that’s a start.

I have been working with SanDisk Support since August 11th trying to solve this problem  with my Clip Sport.  I am trying to sort my Podcasts not Audiobooks.  I have had 2 Clip+ in the past and they ordered my Podcast in the order I copied them to the device.  Although this was not ideal because it took more time to copy my files to the device, I could live with it.  I, like the previous people who have posted to this thread, cannot get my Podcast to sort properly no matter what SanDisk Support has me do.  I have tried removing the details to make sure nothing odd is on the files before changing the title or #, but they continue to sort randomly.  The support techs even logged onto the site where I download my podcasts from and ran a test and magically, theirs were in order.  Either they are running a different version of the firmware or the devices are different.  There is no other explanation.  The techs have been very polite through this whole process, even when I told them their firmware stinks.  If I have to go into the properties and change the details on each file to get them to order properly, that is NOT a satisfactory solution as far as I am concerned. Why can’t they be sorted by file name.  Why can’t they give you an option that allows you to pick how they are sorted.   I will be returning this product and I don’t know if I will ever buy another SanDisk MP3 player again.  I have been very disappointed, but if I go back to a Clip +, it does not allow me to add memory which was a real plus on this device.

I wish I could talk to one of their programmers and explain to them that I am listening to a radio program’s podcasts that has 5 files a day, 5 days a week.  I continue to add files until my device is full and then delete some.  I am not just loading a podcast that is 3, 4, or 5 files.  I like to listen to them in order, because they refer to things that have already been discussed, even from previous days. 

Maybe SanDisk could send me a Clip Sport that they have throughly tested with at least 30 files from a program like the one I am listening to.

Very disappointed in this product.

I have no idea if this will help you, but you might want to check it out:  FatSorter, which will help organize your folders and files under a regular folders view.  This might work as a solution-of-sorts for you.  I truly feel your pain.   :frowning:

I have no idea if this will help you, but you might want to check it out:  Fat Sorter, which will help organize your folders and files under the regular folders view.  This might work as a solution-of-sorts for you.  I truly feel your pain.   :cry:

The thread here discussing it:…

And a direct link to Fat Sorter:

By the way, I’m gathering that this issue you’re having is that the Sport’s database is sorting your podcasts in an order you don’t like, based on the files’ ID3 tags in the files.  If that’s the case, unfortunately, modern players tend to use the ID3 tags for sorting, and so if they’re not correct, so can go the sort order . . . . 

While I try to edit all my files’ ID3 tags, I do see how it can be a hassle with often short-lived and numerous files like podcasts.  Fortunately, perhaps in part because of this, many of the Clip players also let you select files under the good, old folder view, just like on your computer.  Fat Sorter, apparently, can easily help fix a glitch that can develop in the ordering there.