Playlists locking up Fuze+

I have an 8GB Fuze+. I put together some m3u8 playlists on my SD card through MSC mode a while ago, and they work fine. Now, however, I try to add another one, and it locks up the Fuze+ as it loads. I don’t know exactly why it does this-- I have it formatted in the same way as the other m3u8 lists (in the same directory as the songs, saved in the exact same way, etc.

At first I thought the Fuze+ had too many playlists on it (I only had 3 before trying to add a 4th) but after removing one, the new playlist still locks the player up. I’ve also tried renaming files, using different types of playlists (.m3u, .pls)-- still not working. This is really upsetting me-- if the other playlists work, why doesn’t this one work after doing the same steps to make the others work?

What version of firmware do you have?

Whoops-- forgot to mention that. It’s the latest firmware-- 1.32.

OK, I figured it out (finally!). It’s a simple matter of the Fuze+ not liking file names on the MP3s that are a certain length. I don’t know exactly what that length is, but the longest filename I had was 155 characters long. Shortening the names to be more in line with other files in the playlist solved the problem, and the playlist doesn’t lock up the player anymore.

Yes, I just asked in case that might have been a problem in earlier firmware versions.

That makes sense as longer filenames makes the Fuze+ database do more work in terms of refreshing, so incredibly long music filenames might slow the player down so much that the player freezes. Glad you solved your problem, though.