Problem with playlists ( M3U, M3U8's)

Hi all, I’m at my wit’s end with some playlist problems, that I think might be a series of bugs. If it’s something in my logic, however, please let me know. I’ll explain below, with more details but here are the three basic points:


1) M3U’s and M3U8’s do not behave properly (as they do in the Fuze, on your computer or in say, a PSP) in the Fuze+

2) Rather than flat out not working they act all bizarre, and do show up (so I assume m3u’s are intended to work on the Fuze+)

3) M3U8 Files show a . at the end of the name, probably due to using a trim function to display rather than delimiters.

—————————————————————

So here’s how I encountered the bug(s). I have an microSD card with a number of playlists and files from my Sansa Fuze (v1) that I plugged into my new Sansa Fuze+ hoping it would work. Songs enumerated fine, and all the playlist showed up but the first few I looked into were empty. I figured ok, they did something new and they just won’t work, then I noticed two things: 1) One of my playlists was actually populated. 2) Some of my playlists had an errant period <.> at the end of the name  

Regarding item 1)  It’s an M3U8 playlist that contains about 530 songs, all of which show up in the playlist on my Fuze. On my Fuze+ only about 117 songs show up in the playlist. Browsing by songs on the Fuze+, to the best I can tell all of the songs are recognized and listed, just not in the playlists. Trying to be cute I made a copy of this file “Drift.m3u8” to “Drift+.m3u8” and the latter did not appear at all in the list (first bug apperantly some characters cause the Fuze+ playlist to not enumerate the playlist file). I then changed it to “Grift.m3u8”
The files “Drift.m3u8” and “Grift.m3u8” are identical except for the name, on the Fuze both list all files, on the Fuze+ Drift lists 117 files and Grift is empty.

Regarding item 2) The m3u8 files don’t show properly. Drift.m3u8 shows up as “Drift” on my Fuze and “Drift.” on my Fuze+. I suspect rather than dropping extensions, the coders trimmed the last 3 characters off the filename to display.

—————————

To do further testing I grabbed an empty microSD card (1 GB / Class 2 card) and put the following layout on it

/—
 |- Audible
 |- FastJPG
 |- Music
 |   |-Judy And Mary
 |   |   |- Sobakasu.mp3
 |   |   |- Overdrive.mp3
 |   |-m.o.v.e
 |   |   |- 創聖のアクエリオン.mp3  <–This file has proper kana
 |- Podcasts
 |———plus_test_nonutf.m3u
 |———plus_test_badutf.m3u
 |———plus_test_utf.m3u8

  The contents on the playlist files are as follow:
   
plus_test_nonutf.m3u
#EXTM3U
#EXTINF:252,Judy and Mary - Sobakasu
Music\Judy And Mary\Sobakasu.mp3
#EXTINF:303,Judy and Mary - Overdrive
Music\Judy And Mary\Overdrive.mp3

plus_test_badutf.m3u
#EXTM3U
#EXTINF:252,Judy and Mary - Sobakasu
Music\Judy And Mary\Sobakasu.mp3
#EXTINF:303,Judy and Mary - Overdrive
Music\Judy And Mary\Overdrive.mp3
#EXTINF:318,m.o.v.e - „“Â}¤Î¥¢¥¯¥¨¥ê¥ª¥ó
Music\m.o.v.e\01.???.mp3            <— this file has junk

plus_test_uft.m3u8
#EXTM3U
#EXTINF:252,Judy and Mary - Sobakasu
Music\Judy And Mary\Sobakasu.mp3
#EXTINF:303,Judy and Mary - Overdrive
Music\Judy And Mary\Overdrive.mp3
#EXTINF:318,m.o.v.e - „“Â}¤Î¥¢¥¯¥¨¥ê¥ª¥ó
Music\m.o.v.e\01.創聖のアクエリオン.mp3           <— this file has proper kana

—————
On the Fuze everything plays/lists as expected (which is to say everything lists except for the 3rd file listed in plus_test_badutf.m3u because the address is junk.)

On the Fuze plus, the playlists are marked as empty, but the songs will play from the song list.

The Playlist Window on the Fuze Displays:
GoList
plus_test_nonutf
plus_test_badutf
plus_test_utf

The Playlist Window on the Fuze+ Displays
Music Go List
My Top Rated
plus_test_nonutf
plus_test_badutf
plus_test_utf

——————————

I figure the Fuze+ is meant to use m3u/m3u8’s or it wouldn’t even list them. If it doesn’t, I could live with it so long as someone could show me a way to transcribe what I have to something that will work on the Fuze+. If people want copies of the Drift.m3u8 and Grift.m3u8 files to help troubleshooting let me know. I figured people wouldn’t care specifically as there are 500 entries in the files and they won’t do much good without enumerating the mp3’s which other people probably don’t have (or don’t have the time to make dummy mp3’s to enumerate). Any help would be grand. If it turns out it’s a bunch of bugs, a fix or work around(to th tune of the m3u conversion) would be grander.

Thanks,

-Kal

UPDATE:

It seems the M3U / M3U8 parser will NOT accept subdirectories. At the moment M3U’s will only work if you have a flat directory structure with the m3u style playlist in the same folder as the files.

I added a bunch of X-Japan stuff to my player today

Put them on the SD card in the Path    :   \Music\Music Tracks\X-Japan*.mp3

 I then created two playlists, one called in-dir at \Music\Music Tracks\X-Japan\ and one called out-dir at \Music\Music Tracks\

Both work fine on the computer and Fuze. On the Fuze+ the outdir list shows as empty while the in-dir list is properly populated.

Guess the parser needs a rewrite or something.

I’d just like to confirm: are the m3u lists working OK when in the same directory as the music?

Bob  :dizzy_face:

Yes, If a music file linked in a m3u/m3u8 playlist happens to exist in the same exact directory as that list-file, it will show up in the list.

Kalidor I noticed you are using m3u8 playlists. Would you mind telling me which application you are using to create these, so that music with foreign characters show up in my Fuze. I have been looking for a linux application that would do that and have not found anything.

Hi Whitepine,

 Unfortunatly, I don’t think I will be of much help. For testing purposes I’ve been using winamp. To actually populate my SD cards / player I have a custom program I’ve been working on that takes the lists I made and saved on my NAS, transfers the linked files, then creates a new m3u8 on the sd card, by creating an empty file with the BOM up front and linking all the copied files.  Haven’t actually done much of the management on my *nix boxen.

That said, I believe both VLC and XMMS will save m3u8’s. VLC saves the wrong file extension (at least on windows) but the BOM is still present so you just need to redo the extension for devices/apps that require the m3u8 file to use the m3u8 extinsion.  Sorry for not being as much of a help.

-Kal

I just created an M3U playlist as follows for a test and it is working no problem. I created 3 folders in the music folder  for this test i used  folders 1, 2, and 3  each containing one song that is in the playlist along with other songs that are not and the m3u playlist is in the root of the music folder. 

can you give this a try and let us know if it works for you. 

the m3u playlist looks exactly like this

#EXTM3U

1\25 to life.mp3

2\almost famous.mp3

3\cold wind blows.mp3

to me that’s not much better than the existing solutions which is to use MTP transfer with WMP. I want to be able to go into the Fuze + in usb mode and create playlists from music I already have on my player.

Hi drlucky.

Thanks for checking. Let me make sure I actually did what you told me to. Here’s the file system as I manually created on my SD Card:

  • TEST SDCard

 |- [Music]

        |--  drlucky.m3u

        |—- [1]

        |         |— 25 to life.mp3

        |

        |—- [2]

        |         |— almost famous.mp3

        |

        |—- [3]

                 |—- cold wind blows.mp3

I created the M3U by copy pasting your message :

<================>

#EXTM3U

1\25 to life.mp3

2\almost famous.mp3

3\cold wind blows.mp3

<================>

Results:

   VLC - Works OK

   Winamp - Works OK

   Car Stereo - Works OK

   My Fuze  - Works OK

   My Fuze+ - playlist <<Empty>>

   Wife’s Fuze+ - playlist <<Empty>>

So I guess no joy.

I also checked my firmware version to be on the safe side: 01.32.00 A  

My Apologies Markymays, I think I gave more weight to m3u/m3u8 part of the question then thinking of the procedure.

For myself,  I would normally (say for my fuze in which the m3u/m3u8 parser works perfectly) would just drag the audio files I want (or the folders within which they are) into my winamp playlist. Which I would then simply save as an m3u or m3u8 on the files system of which ever flash memory module you are using. (in MSC mode each would load as a seperate drive, and of course I am assuming by USB mode you mean MSC not MTP). Winamp is pretty smart and will save the file relationally instead of globally if its in the same file system (in other words won’t reference a drive letter if you are saving it in the same tree).

Of course the problem here is that in order for this to be of any use the parser has to work, which as of right now, I’ve seen no joy.

As far as MTP mode, your options are limited because MTP mode essentially accesses a bunch of blackboxed api’s within the device and those do your playlist for you. You have to rely on whichever program you are using to able to make proper use of those blackboxed interfaces, rather than dealing directly with the file system. (This of course has another nasty side effect in cases of the SD card. An SD card which has an MTP made playlist that I create on my Fuze+ simply won’t work one my Fuze without me redoing them on the latter device.)

I rambled a little with that last one and went techy. Let me know if I need to decode anything in there.

@kalidor wrote:

 

my SD Card:

 

  • TEST SDCard

 |- [Music]

        |--  drlucky.m3u

        |—- [1]

        |         |— 25 to life.mp3

        |

        |—- [2]

        |         |— almost famous.mp3

        |

        |—- [3]

                 |—- cold wind blows.mp3

 

 

 

can you try it on the internal memory? i am not using an SD card but that could be the issue here as well. 

Found my cable, copied drlucky.m3u and the three directories over to the internal memory.

I tried it against VLC and winamp and it worked fine.

Ejected the device, turned it off, pulled the sdcard (so there would be no uncertainties about which playlist it is).

Turned it on. Playlist still empty.


SANSA FUZEP

 |- [Music]

        |--  drlucky.m3u

        |—- [1]

        |         |— 25 to life.mp3

        |

        |—- [2]

        |         |— almost famous.mp3

        |

        |—- [3]

                 |—- cold wind blows.mp3

stick with it, mate, I’ve about given up :frowning:

Well, I did end up reporting this over the phone about a week after opening this thread, and referred the thread. I was told it would be sent off and did get someone who called back confirming some questions and replicating my findings.  The rewrite for the parser should be fairly straightforward and I am expecting it in the next firmware release. At this point I have trouble seeing it as a technical issue and being more of a ‘not important’ to the team lead issue, if it doesn’t show up.

If that’s what happens then I’m afraid the product’s sunk for me.

As it is, I am mostly sticking with my old V1 Fuze 'till I can get the SD cards from that working seemlessly in the Fuze+. Ironically, one of the main reasons I wanted to upgrade to the Fuze+ was to be able to use more of my music on my portable (wider format support), instead I get to use less of it.

@kalidor wrote:

The rewrite for the parser should be fairly straightforward and _ I am expecting it in the next firmware release. _

 

I wouldn’t. Once a bug/glitch/problem/issue is reported it takes time to confirm it, fix it and test it to make sure the ‘fix’ takes and doesn’t ‘break’ anything else. I doubt very seriously at this point in time that it would make the next update.; it’s probably already in the (QA) testing phase. No additional recoding is likely to be added.

Realistically, you’re probably looking at a few months to see any action on it.

not sure why it is not working on your. Like i said before m3u playlists work fine on my fuze+ if created like I described earlier in this post. if they cannot recreate your issues it is unlikely they can fix it. 

Dunno, all I know is I can only get it to work when it’s a flat structure on the Fuze+. Manually created, or winamp created.

And to be truthful, considering winamp essentially wrote the filespec for m3u, and it works on everything except the two Fuze+ I have is beyond me.  I will say I have tried them in MTU, MCP and Auto mode, and I haven’t seen it behave any differently in either. The paths are relative to m3u/m3u8’s in all instances , not root relative or global.  And as I said before … I did get a call back from someone at SanDisk and did have the error confirmed.

I’d love it if it was a simple fix like wrong firmware or something, but as of right now I can confirm out least 4 fuze+ that all behave the same and I’ve tried toggling every setting I can think of.

can you PM me the m3u file you created so I can take a look at it?

I’m still having this problem. I have a playlist where some of the songs are in the same directory as the m3u file (these songs are recognized) and some in folders (these are not recognized). Could it be that the songs are in nested folders? Example:

-playlist.m3u

-song1.mp3

-song2.mp3

-Artist1\Album1\song3.mp3

-Artist2\Album2\song4.mp3

There are also spaces in most of the folder names and song names if it makes a difference. Example:

Alice In Chains\Greatest Hits\02 - Them Bones (Album Version).mp3

Suggestions?