Playlist problems on 8GB Clip+...

I’m at my wits end.  I’ve most successfully used the Windows Explorer method of creating the playlists, for my new Clip+, but when I disconnect the player and go to see the results, the first playlist that is brought up becomes the ONLY playlist that works.  It doesn’t matter if I hook it up again, delete and re-create them via computer, changing the USB settings or anything.  Once disconnected from the comp, I go to and pick any playlist, the player will take a second or two to apparently, bring up the list, and it is successful. But if I go back and try to pick a different list, the SAME SONGS from the FIRST chosen playlist are loaded.

I’ve tried using different USB connections that I read about here in the forums to no avail.  I’m faced with the same problem as above. Here’s some other methods I’ve recently tried to create playlists, and none have fully worked:

  1. Using WMP, but this was before I found the MTP USB setting, and not it appears that I’ll, again, have to delete all my content from the player and re-insert it using WMP in order to (maybe) try and create the playlists again??? I don’t think so.

  2. I’ve tried using that free app “Sansa Clip Playlist Creator” but it doesn’t even see the Clip when it is connected, no matter what USB setting is used.

  3. Using the free version of “Playlist Creator for SanDisk Sansa Clip 2.32” results in “No Music or Audio Files Found” if I try to create a playlist choosing any other folders than the “Music” folder in the player. Meaning I cannot pick any of the downloaded files currently in the player. Which kind of defeats the purpose in creating a playlist, really.

  4. Using Playlist Creator 3.6 as suggested for a similar playlist issue on this thread:
    …results in the created playlists as showing empty in the player menu.

From a further search of the forums, my issue sounds similar in nature to what “belowzeros” had on his unit at this thread:
…but I’m not using Winamp, and am on Win7.

What am I doing wrong here?  Are playlists of more than a few hundred songs too big, perhaps? I just can’t figure it out. It should not be this difficult!! I’m far from computer illiterate, so I’m confounded when I cannot find a solution to this problem anywhere, after more than 8 hours of working at it. I’m prepared to send this thing back re-formatted and be done with it, or launch it into orbit, I’m so frustrated.

Some progress!  I had hoped that something like this would have happened before my first post, but that’s how things go sometimes, I guess.

Anyway, my “work-around” or whatever it is seems to be moving at least one playlist to the Playlist folder, as opposed to leaving it in the Music folder.  So, whereas I once had 5 different playlists, I’m now down to two, both working (at the moment!) and reading the correct contents, but in different folders.  I’m going to experiment with adding another to the Playlist folder and see how that works.  Previously I fiddled around with the m3U (?) format, but that resulted in more empty playlists.

Is this really strange, or can someone make sense of this for me?  I’m going to go with what works, but this is extraordinarily frustrating, and I didn’t want this stupid thing to win.

Well, now I feel like the biggest fool ever… nearly everything I had read up to now had said that it didn’t matter if you left your playlist in with the Music folder, and some even said it was NECESSARY that they were.  Well, I’m here to tell you that they do not.  At least in my case.  It might actually HELP matters if they’re ALL in the Playlist folder.  Because that was my solution.  <sighs>  I now have three working playlists, and maybe more in the future!  It’s a miracle!

Thanks for helping me air out my frustration!  And no one had to say a word to me… ha ha…

I’m looking forward for a happy future with my Clip now… no more threatening to launch it into orbit, I swear.  At least in the immediate future.

Thanks again!


Thanks for your post and the method you describe.

Would you mind posting an example of a playlist file content so that I can compare the file structure in it with my own playlists always empty…?



Greetings Olivier, I’m not sure how else to post an example of my playlist file content other than a picture, so I uploaded one here for you to have a look. It’s a snippet of the Explorer window with the playlist window on top of it, showing a portion of the classical playlist. This is an example of the .pla format playlist. I did give the .m3u playlist a whirl when I was messing with one of those “playlist creators,” so maybe you might want to give one of those a try.

I created these playlists straight from the Explorer window. Simply click on the MUSIC folder on the left pane, and then, using the Ctrl button, click on each folder of content in the right pane that you wish to be in a single playlist, and when you have all that you want highlighted, right click, and go to “Create Playlist”.

I am in Win7, and to make this work, you should make sure you have the MTP USB setting selected in the Sansa’s settings, though I think it worked by default for me when I plugged it in the first time.

I hope this helps!

This is just a suggestion to anyone who has playlist problems. I have two solutions that have worked for me.

  1. Delete your existing playlist. Disconnect from computer, shut down clip. Reconnect to computer, create a new playlist. It’s kind of like rebooting your computer and clearing out the virtual memory.

  2. In windows explorer, delete your playlist, move your mp3s from one directory to another (cut and paste), then create a new playlist. I’ve actually had ID tags straighten themselves out with the cut and paste (don’t know why, just know they did). 

And I have to do one of these things each time I put a new MP3 on my clip. The first works 90% of the time, and the second works 100% of the time, but the second takes longer, so I always try #1 first. 

Hope it helps someone else.