Play All Under "Artist" says "No Song"!!!

I’ve had my express for a while now, and i’ve finally come up with the courage to try and fix it. It will turn on, but will not play music if i go under the following:

Music/Artists/Name of Artist/Play All/No Song

As son as i press play all it comes up with the response "No Song."
I have already tried the hard reset (vol+ and grey button) for more than 30 seconds, and i’ve also tried formating it many times, but it still comes up with the “No Song” message.

If anyone has been able to sove a problem like this or has any comments please answer back.

After formatting, you do load music back onto the player?

Formatting will delete all the music and playlists (will delete
everything.)

-r

I know exactly what you mean! The same thing happened to me, and I had songs on there…someone suggested I re-format the player, I haven’t tried it yet, but that might work…

I have already formatted the player completely. Once by doing the format internal drive menu in settings, and another time by holding the (vol+ and grey) button for over 30 seconds. Both of these deleted all information on the player. I did that and i also did a system reset (electronic and hard reset), and I also did the firmware update but it still says “No Song.” I have tried everything i can think of but nothing works.

I have the same problem. My firmware is uptodate and i have reformatted it. I use Rhapsody to transfer. Also sometimes when i go to the Music/Artist/Album, it does the same thing, only it says empty. When i return to the last menu it says epmty too. Has this happened to anyone else? Thanks.

i have the same problem…
i have formatted and installed newer firmware
and i drag-drop the songs(i tried window media player and all other stuff more than 10 times now…)
and when i go to artist and ‘play all’ songs it says “no songs”
but when i go through albums or songs, this stupid sansa express has my song and it plays…
after doing that
when i go back to artist and do “play all” still ‘no songs’
even though SE has that song and recognize it when i go to ‘albums’ or ‘songs’ and find that song.
makes me so freaking mad.
so every time i want to play certain song, i either have to go to albums and look for the album or go find the actual song which such a time consuming, painful act.
can Sandisk come up with new firmware that can fix TONS of STUPID bugs?
or did they just gave up on SE cuz it’s pretty much POS?

I have the same problem too. I figured some stuff out. If you search from Artists, it’ll say “no songs”, but if you search from the album, sometime it finds the songs. same thing for play all, it will play the song. very weird, must be a bug.

Any update on the problem? Any solution perhaps? SanDisk people - why haven’t you fixed the bug in the latest firmware?? I think it’s the worst bug there is now!

BTW Here’s my description of the bug that I wrote for fixya.com. If someone just encountered the problem this should save you some time…

Descripiton of the problem:
When I try to play songs by going Music->Artists->[artist], very often (I’d say 2/3 of my songs) I get a “No song” message. When I go through Music->Play all, all the songs are played correctly.
(Also, it’s impossible to play the songs in Winamp directly from the player, and Winamp crashes instantly after plugging the player in, and won’t open as long as it’s connected. Though I don’t know if any the problems are connected. Of course the one with the “No song” message is the only serious one.)

What I’ve tried:

  • I’ve tried (of course) formatting the player, both using itself and using windows.
  • I’ve tried resetting the settings.
  • I’ve tried messing with ID3 tags, removing them, adding, trying only with a 1.1 tag, only with a 2.x tag. When compared to a different file that plays correctly no apparent differences in tagging can be found.
  • I’ve tried moving the file, and a strange thing happens. Randomly the file after being moved (like from the Music folder up to the main catalogue or to a new folder) behaves normally or shows the “No song” message. I’ve tried having two files on the player and moving them around folders (including the SD card), and their behaviour concerning the bug is completely random.
  • The firmware is up to date, but I don’t know if the bug occured before updating it - it was the first thing I did after getting it yesterday.
  • I’ve tried removing the SD card, formatting the internal memory and putting some songs in - same thing happens.

This bug really kills much of the player’s funcionality (can’t browse artists). Please help!

Can you give examples as to the ID3 tag content you’re using?  Also, where did the tracks originate (what format, which program created them, etc?)