Anyone else experiencing random problems with their Express???

I’m trying to figure out if my device is malfunctioning, or the whole line is defective.  Anyone else experience the following on a random basis?

Player will start playing an album from some random track, and the middle of the song?

Player will not allow me to delete anything, stating that the disk is full, but in reality it’s not?

Player will eventally fail to power up, requiring me to put it into recovery mode and reflash the device?

EQ randomly resets your custom settings to flat, and defaults to normal mode?

Playlist shows doubles of all tracks in a random album, and actually plays the doubles like they were actually there?

Tracks in an album randomly dissapear from the playlist, even though they still exist on the device?

I like the fit/form of the Express, but if this series is buggy, I may have to resort to a different player…  :( 

Also, sometimes the display will not turn off, nor update the progress bar.

Every one of these problems seem to be pretty standard with this player. I’ve had nearly every one of them.

  1. Player will start playing an album from some random track, and the middle of the song? This happens quite regularly. I’ve not solved why but I think it tends to happen once you’ve been using the player for a while, deleting and adding new music.
  2. Player will not allow me to delete anything, stating that the disk is full, but in reality it’s not? This seems to happen at the same point as above. The only solution I’ve found for this (which also appears to solve above for while) is to format the drive (internal and/or external) and re-add songs. It’s a real pain.
  3. Player will eventally fail to power up, requiring me to put it into recovery mode and reflash the device? I’m not sure I’ve had this one. Is this the problem where the player gets stuck at the SanDisk logo when you switch it on, or is that yet another problem.
  4. EQ randomly resets your custom settings to flat, and defaults to normal mode? This just seems to happen at random every so often. I’ve yet to find a common reason for why custom settings reset. Sometimes it’ll go for a while without it happening then sometimes it’ll happen three times in a day!
  5. _ Playlist shows doubles of all tracks in a random album, and actually plays the doubles like they were actually there? _ I’ve found the best way to solve this is to delete the album and re-adding it. I think that doing one of those “select and +” resets seems to help here, although once again that means sacrificing settings. I got so fed up of resetting settings that I just don’t use the “radio preset” or “go list” functions.
  6. Tracks in an album randomly dissapear from the playlist, even though they still exist on the device? This is probably the 1000 song problem. You’ll probably find that the tracks all have titles that begin with letters towards the end of the alphabet. Unfortunately the problem is that as soon as you put more than 999 tracks on the player it has problems indexing them. For example, if you have 1002 tracks on your player they will be order a-z and the last three tracks towards the end of the alphabet (tracks 1000, 1001 & 1002) will not get indexed and therefore are unplayable. As a result, when you first discover it you wonder why the album skips tracks. It is a pain and the only solution is to keep an eye on how many tracks are currently on the player (which can be found by going to settings>system info) and not letting that figure get over 999. Of course, you could be having a different problem but if you have over 1000 songs on the machine then this is likely to be the problem.
    There’s a number of other delightful problems you’ve got to look forward to as well but unfortunately SanDisk apparently aren’t going to be releasing any more firmware for this crappy player so we’re stuck with all these problems until we buy a new player or someone works out how to setup rockbox or something similar on the player.

Message Edited by darcyscarrot on 04-23-2008 04:05 PM

Message Edited by darcyscarrot on 04-23-2008 04:06 PM

@backinblack wrote:

I’m trying to figure out if my device is malfunctioning, or the whole line is defective.  Anyone else experience the following on a random basis?

 

Player will start playing an album from some random track, and the middle of the song?

Player will not allow me to delete anything, stating that the disk is full, but in reality it’s not?

Player will eventally fail to power up, requiring me to put it into recovery mode and reflash the device?

EQ randomly resets your custom settings to flat, and defaults to normal mode?

Playlist shows doubles of all tracks in a random album, and actually plays the doubles like they were actually there?

Tracks in an album randomly dissapear from the playlist, even though they still exist on the device?

 

I like the fit/form of the Express, but if this series is buggy, I may have to resort to a different player…  :( 

 

The Express is picky about its ID3 tags. This may be the cause of the first problem you describe. I found that syn’cing songs with WMP or dragging songs with the player in MSC mode works the best for me. When dragging songs in MTP mode, I ended up with some corrupt songs that had erratic behaviour. First, make sure that your songs are all properly tagged.

 

Corrupt files could also be causing your second problem. Try placing your player in MSC mode as described by Thomas in the attached Link, then run check disc on your player to remove any corrupt content. http://forums.sandisk.com/sansa/board/message?board.id=express&thread.id=1012

 

I haven’t had the power up issue that you described.

 

My Express loses its settings regularly. Often it starts with the “Select Language” screen. Re-flashing the firmware has not taken care of that problem.

 

The last two items are caused by the Express’s database getting corrupted. It may be related to your songs losing their ID3 tags or getting corrupted while on your player. Once the ID3 tags get corrupted, the songs disappear from the Express’s menus. One way to get the database to update is to add or remove a song, once you disconnect from the computer your player will refresh the database. If this doesn’t work you may have to format your player and transfer all songs back onto the player.

 

 

 

darcyscarrot wrote:

…I got so fed up of resetting settings that I just don’t use the “radio preset” …

LOL, same here. I didn’t mind resetting the FM stations the first, or second, or third time. But after a while, I also got tired of resetting the stations and quit using the radio. But, I have quite a few other FM radios. So it is more of an annoyance than a real problem for me. I sympathize with anyone relying on the Express’s radio function. 

 

The Express is a great concept with great features, but it was poorly implemented and supported by Sandisk. I still give it good grades with respect to what you get for the price. It is a good player, it could have been so much better.