Okay, here it is:

i got my sansa express as a gift about 2 months back, and it was working fine…until recently. Everytime I tried to return to the menu from a song, the player would turn off. I tried erasing all my songs and putting them back on, and that seemed to solve that problem, but there was some new strange behavior, like, when i tried to go back to the menu, it would go to a completely different song’s list, or if i tried to play a song, it would give me an error: No song, when there actually was a song. I tried a firmware update, but that didnt work either. So now, the situation is: i have an unpredictable player that sometimes has these various problems, and sometimes seems to work ok. And I am at a loss for what to do. Help please? Thanks :slight_smile:

i hear the player has a reformat option from the settings menu.  maybe try that and see how retransfering your music works for yas

If that fails, then hard-reset the SE.

If that fails then (I would avoid this as much as possible), update the firmware.