Pendrive Not Showing

My Pendrive not showing in explorer.Driver had installed sucessfully. i have tried reinstalling driver it doesnt work.,Please Help me…

:smiley:  Hi, naveen8384

Please, test on other PCs, your pendrive, to define the problem.

Then, if not work, return it, is defective.

But, if it works in other PCs, see:



Regards, Alfred.

Has this working in the past? Or is this the first time to use it? Try Windows update since Sandisk uses Windows built in drivers. What OS are you using too? 

Hmm… is there an echo? (and 2 days later…)

It worked fine for few days then it is not showing drive.It is showing in device manager.

:smiley:   Hi Naveen8384,

Friend, I suppose, that tested the Cruzer in other PCs…

Well, in the photo that you sent (thanks), see also in the last item: Universal Serial Bus controllers (Step 3).

Also, please, analyze the following:

1-   In the _Control Panel / Administrative Tools / Event Viewer: _ see if there is information on this item.

2-   See also, in the _ Task Manager, the processes which are running,_ and see what are the necessary and what to delete.

Because, there are some services programs, telephones and video cameras, that cause system conflicts, by interference in USB ports, such as: Samsung Kies, HTC Sync, Sony Play Memories, Motorola, etc.

3-   In the _Control Panel / Administrative Tools / Computer Management / Device Management Tools / Universal Serial Bus controllers. _

See if a USB icon is crossed out with red, or there is a yellow question mark.

4-   See, also, for a teaching with images, the links:

5-   There might be a conflict, between drive letters being used:

6-   Maybe what happens, is that there a corrupt line in the registry/USB, that detects this UFD as “problematic”.

Also, the intensive use of USB ports, generates “USB junk” in the registry.

Then, to clean, easier the “USB junk”, you can use (app portable, free): USB Scrub Cleans 1.00,

7-   If the above steps have not solved the problem, _contact SanDisk Technical Support _ who will replace the device, if it’s authentic and is within warranty.


Luck, and then you tell us , what happened, please.

Regards, Alfred.                                                            (Google translated)

I have a Toshiba C660 laptop usually running 32 bit Windows 7    (Hard disk is partitioned and can boot LinuxMint16 instead)

A recently purchased Sandisk Cruiser Switch  seems to have same/similar problem as yours.

(and a TKD 8gb USB3 not recognised at all)

However, if I choose the Linux program at startup, i can see these USB sticks and copy files to or from them.

I have done this a few times,  e.g. to put files on my Daughter’s Sandisk which works OK on her computer, but not on mine

when using windows.

I suppose there may be drivers and programs available which would sort out the problem for  Windows on particular computer models. I haven’t gone that way because it seems that it may not be all that straight forward.

A friend has also used a Linux  bootable DVD (rather than Linux installed on the hard disk) to do view/copy files,

  • as a matter of curiousity in his case-.

If I get a new computer sometime, I would be tempted to have such a Linux DVD in my back pocket, just in case.

Originally I thought I had a bad Sandisk, but it seems to be some sort of compatability issue.

Hope all ended well in your case, just thought I would mention all this as a matter of interest.