PC will not recognize Cruzer flash drive

I have a Sandisk cruzer 8 GB flashdrive (Model# SDCZ36-008G). I can use it succesfully on several computers except one. All the computers I have tried it on are running Windows XP. When I insert it in this one computer, it attempts to install the drivers, and I get the following error;
“Error Code 28 - The I/O operation has been aborted because of either a thread exit or an application request.”

I can see “Sandisk Cruzer” in the Device Manager listing, where the properties say it is not installed properly. I cannot see it in a Windows Explorer tree.

I have tried to use it plugged into a HP printer’s USB port, but the printer also will not recognize it (this worked for another makers flash drive that also would not work on this PC). I have also tried it with a (non-powered) USB hub, with the same results.

What can I do to remedy this?

Replace the PC.  :wink: 

Try running a CHKDSK on the C: drive.  And maybe a repair, or fresh, install of XP on it so the driver files are all ok.     

Uhh, i also had the same problem, but with my 16gb sandisk cruzer flashdrive… i just installed ubuntu (beside windows) with wubi-installer from Ubuntu, and after that, i rebooted my pc and dualbooted ubuntu from the boot screen. then i plugged my usb flashdrive into my pc, and the usb appeard on the desktop in ubuntu. after that, i just rightclicked on my usb flashdrive and looked for “propeties” label. when i found if, i pressed it and looked for a label (i dont know what its named in english… i used the swedish verison of ubuntu) on the first page of propeties thingy, i think it was “hardware manager” or “look for the device in the hardware manager”. then i went to that thing and looked for my flashdrive. when i found it, i looked for the formatting button. then i clicked on it and i formatted it to “ntsf”. when ubuntu formatted my flashdrive, i rebooted my pc again, but with windows. then i went over to U3 Sandisk page and downloaded the file named “LPinstaller.exe”. then i reinstalled U3, and it was as new again!

Im sorry for my bad english, but i hope this helped you.

I’m having the same problem. My windows 7 PC won’t recognize the Cruzer USB 2.0 Flash Drive.

I removed all the accesories from the USB ports, except for the mouse, keyboard and Cruzer flash drive. Then I rebooted the PC.

The PC found the flash drive but displayed these messages:

Universal Serial Bus controllers

Standard USB Host Controller)


Windows has stopped this device because it has reported problems. (Code 43)

The best driver for your device is already installed.
Windows has determined the driver for your device is up to date.

…What is my next step?



This thread may help:


Find an XP machine to do the upgrade.

OK. I’ve downloaded the U3 launchpad installer onto my XP machine, and it’s asking me to insert a U3 SmartDrive. What is that? Do they mean the 8gb flash drive, or something else?

  • Roy

I got the same problem, the flash drive was working just perfect for 10 days exactly, i was copying a divx movie, it finished the copy, then i put it onto Divx Portable Player, and it said that USB is not valid, then i return ti my laptop, and GOSH!!  Unknown device pop ups every single time that i plug it into a usb port. Change laptop, the same, put it usb into car stereo, the same, not a valid usb. I’ve made it all, the power supply turn off solution, the uninstall from control panel, the update driver option, i refused to think that is a hardware problem, because it went from good to bad, in less than a minute. Thank you in advance for your help. I’m from México, english is not my native languaje.

I am having this same problem with my 16 GB Cruzer Flash Drive.  It works in my netbook but not my desk top.  The installer can’t find a driver.  What did others do to fix the problem.  I downloaded  Windows Service Pack 3 hoping that would help but it didn’t.  A