PC cant see Clip

Tried 2 different laptops - one vista/one xp. Neither machine can see the clip. What am I missing ?


If not done, set USB Mode under Settings to MSC and try again.

Thanks for the reply - I have just retried this. Still not seen

On the Clip’s display, let us know what you see.  Does the Clip power up when plugged in to the USB port?  Does the display state “connected”?

Are you using the supplied Sansa cable, or a different (as from a digital camera) one?

Open the Device Manager and look at the Universal Serial Bus Controllers entries at the bottom of the list.  Do you see any trouble icons, wee yellow warning triangles?

Bob  :dizzy_face:

Doesn’t power up when plugged into the USB. Doesnt state connected.

Using the sansa cable supplied

No warning triangles in device manage.

Cheers Bob

My wife has recently bought a Sansa Clip 1Gb and has tried to get it read on 2 PCs and a laptop now, none of which worked.

The Clip powers up when plugged in.

Its been plugged into front USB ports and rear USB ports.

Following guides to get it into MSC mode seems to have no visible effect on either the PC or the Clip. 

It doesnt state it is connected … it just defaults to the FM radio.

We are using the Sansa cable provided.

There are no warning triangles in device manager.

Uninstalling and re-installing the USB Mass Storage Device driver deosnt seem to work either.

Should we format the Clip? I’m aware that there are some sample tracks on there already.

Does it charge when you plug it in to the computer. If it does and the radio plays there is a data connection no being made somewhere. I doubt formatting would help but it won’t hurt either.

Thank you for the prompt reply Dave :slight_smile:

To answer your points …

It doesn’t seem to charge when plugged in, despite having the flashing battery logo in the top right of the screen. After leaving it there for 5 hours of charging time, when unplugged, switched off and then back on, it gave a “low battery” warning and then died on us.

Are you suggesting the cable could be at fault?

I will try the Creative one that came with my Zen, as it has identical connectors.

I can happily confirm that it was a cable fault.

The Clip has been recognised by the PC now and its loaded up into a “Connected” screen along with a lovely animated screenie of the Clip & PC happily chatting away.

Many thanks for getting my brain working on this one Dave.

Sometimes you just need to air your thoughts for the obvious to come floating to the top.

*doff hat*

Oh dear …

It seems that I was all a little premature there.

When I said “recognised” I meant … “its made that little ding-dong noise” … and all though the Clip is blissfully believing that it has some kind of relationship with my PC, it seems that feeling is not recipcrocated.

We do have some battery charging now at least.

But despite unistalling and reinstalling the USB Mass Storage Device drivers (again) and trying to get the Firmware updated, its still not showing up in “My Computer”. (windows XP SP2 for those who care :P)

So, could we still be looking at a bad connection somewhere inside?

I’m suffering from the same problem.  Sorry to say I’ve not found a resolution yet.  Someone must have an answer.

Ok had same problem.

turn  on mp3 and go to settings, go to msc and select, then connect to computer, go into my computer and it should show in list removeable disk and also the Sana logo, click on that and it should come up with the list of what you can do with your mp3 player. Open your music files in windows explorer and drag into the Sana music file, once it as copied onto the mp3, disconnect the link from the player. Go to music on the player and then to play all and you should in theory have sound. I phoned the Tech support people in London this morning, got the above instructions from them, this as worked for us, so thought I would write in full what I had to do, hope this helps and good luck.