Sansa Clip will not mount on Windows 7


I have a Sansa Clip (and a Sansa Clip+) that I have owned for several years. Suddenly it will not mount when plugged into a USB port (any port) on either of my two Windows 7 PCs.

The first PC is running Windows 7 Home Premium 64-bit SP1.

The second (laptop) PC is running Windows 7 Home Premium 32-bit SP1.

The Sansa Clip has its USB setting set to “MSC”.

When I connect the Sansa Clip to a USB port the Sansa will start from the “off” state and will indicate that it is being charged (via the USB port). However, the device does not mount and is NOT visible in either the “Devices and Printers” display or the “Portable Devices” under the Device Manager. I have the same result on both PC’s.

The Sansa Clip+ has no problems and mounts perfectly on both PC’s.

I have tried the alternative settings to “MSC” but there is still no connection.

The Sansa Clip worked fine until several days ago when I went away for Xmas. When I came home it has stopped working.

It seems that maybe the USB connection on the Sansa Clip is broken.

Any help would be appreciated.



I see you’re talking about a Clip and a Clip Plus model. One mounts, and one no longer does.

Let’s delve into the first possibility you mention, the data cable. Both devices use the same mini USB connection, so if the Clip Plus connects, the cable is OK. It’s possible that you may have a connection issue within the device, so let’s check a little further.

Start with the known “good” device as an example. When the Clip Plus connects, the display will light, and the “connected” logo will appear. The device’s buttons will be ignored, with the exception that if the display times out, presssing any button will wake the display.  If the data connection is open, the Clip will still respond to the button commands, just as it will when connected to a USB power adaptor.

If you have a Windows Explorer window open and are using MSC mode, WIndows 7 will show the mounted device after a few seconds as a logical drive.  If in MTP mode, the Device Stage will open, and the Clip will show in the task bar with a little Sansa icon.

Now for the fun part. It’s quite possible that the Clip is OK, but something is amiss in the computer’s registry. You can check if teh Clip is OK by plugging in to a second PC to se if it is recognized normally.  On the Windows 7 machine, you can open the Device Manager to correct a corrupted partnership. If the PC goofs up something in the regisrty entry, it will continue to do the same stupid things every successive time the device is plugged in, making it look like the device is dead.

In the Device Manager, find the device in the USB Root Hub and double click on it, then select uninstall. Then unplug and give the computer 30 seconds to settle. Try plugging in the Clip again, and it will set up things from scratch for you.

Bob  :stuck_out_tongue:


Thanks for the reply. I have done all the steps you mentioned.

  • The Sansa Clip lights up when connected to either PC’s USB ports
  • The Clip seems to be charging
  • The Clip is NOT recognised by the PC (there is no “Autoplay” dialogue and the device is not shown under “My Computer” or the “Device Manager”)
  • The Device Manager shows not device errors

It would seem to me that the USB connection software in the Clip has failed or is corrupt.

Its a few years old so perhaps its just died.