password protect

i have two sandisk cruzer both 32gb but they came without any password protect feature - i tried installing the U3 password feateure from my desktop onto one of the flash drives but it came back with the message unable to format the drive and now i cannot even open my drive it says it is corrupted or something - it was fine until i tried to install the U3 what can i do to put my sandsik back to normal and then install the password protect feature

New Cruzers no longer include the U3 software.  SanDisk has dropped support of it.  In addition, new Cruzers don’t support the addition of U3 by the end user.  The best you can do at this point is return them to the store and get your money back.


I have just purchased another SanDisk and can not find where it is password protected.  Is it possible to add this security?

Unfortunately, no.

there are many encryption applications available. just do a google search and choose one you like. 

Unfortunately encryption applications all require Admin Rights on the host and some even drivers on the host.  Fine for home machines but not as useful on public or office machines.

If you want hw security look for Ironkey sticks.

how can I password protect a 8GB Sandisk Cruzer?  I formatted new disk before backing up data.


Try to use folder lock, I’ve tried it before, but it will not password protect the whole flash drive, just the files inside it, does protecting the file and not locking the whole flash drive.

Hope it helps,

Have a nice day

if you use “forgot password” data recovery will not be possible as this is a security feature.