Pass protected cruzer not accessible on win7 and xp. Any help is much appreciated!


I’ve had my 16gig cruzer for a while, but last time I used it was more than six months ago.

Copied all my documents (of great importance of course) and locked it with a pass.

I know the password, which is usually the first thing I forget, but now I can’t get the U3 to launch.

When plugged in a win7 machine it says: “An error has occured while starting the U3 Launchpad due to a problem with one of its components. Remove and reinsert your U3 SmartDrive. If the problem persists contact the U3 Smartdrive manufacturer.”

and when plugged in the xp machine it just creates the following dir:

C:\Documents and Settings\MadFace\Application Data\U3\0000184CA87296B8

Also tried U3 installer, but when I plug in the cruzer it says I need to login and then install.

Thanks for looking into this!

Since you have tried it with a 7 and XP machine, there might be a problem with the U3 Application already. Try to Uninstall and install it by using the LaunchapRemoval Tool. Note that it will erase all files.

You can just try to install U3 app again. U3 installer

hope this helps

the empty folder on the XP machine is caused by an update that disables auto launch. you can fix it if you have admin right by editing the registry. here is a knowledge base article for reference.

Empty folder on on XP

the error on the win 7 machine is most likely due to having an old version of u3 that is not compatible with win 7. unfortunately if this is the case you cannot update it on the win 7 pc. you will need to get it to launch on a pc running xp and disable the password. once that is done you can update the u3 launchpad using the u3 installer stickied at the top of this board. I would suggest doing a manual backup of any data and selecting format during the install process then put the data back on the drive. 

Yes! That’s it!

Worked like a charm!

I can’t thank you enough!

At some point I really tought it was a hardware issue as I’ve not used it a while, but no!

there was a value on the key and after deleting it U3 started immediately!

Thanks man! You saved my life!